kategar
?>

Даны две матрицы а(nxn) и b(nxn), а также два вектора х = (x1, xn) и y = (y1, y2, yn написать программу нахождения скалярного произведения (ах)*(ву).

Информатика

Ответы

helena-belozerova
Const   n = 5; type   tm = array[1..n, 1..n] of integer;   tv = array[1..n] of integer; procedure prodmv(a: tm; b: tv; var c: tv); var   i, j, s: integer; begin   for i : = 1 to n do   begin       s : = 0;       for j : = 1 to n do s : = s + a[i, j] * b[j];       c[i] : = s;   end end; procedure sumv(a, b: tv; var c: tv); var   i: integer; begin   for i : = 1 to n do c[i] : = a[i] + b[i] end; procedure initmatrix(var a: tm; p, q: integer); { инициализация элементов случайными числами на [p; q]} var   i, j, k: integer; begin   k : = q - p + 1;   for i : = 1 to n do       for j : = 1 to n do           a[i, j] : = random(k) + p end; procedure initvector(var a: tv; p, q: integer); { инициализация элементов случайными числами на [p; q]} var   i, k: integer; begin   k : = q - p + 1;   for i : = 1 to n do       a[i] : = random(k) + p end; procedure displaymatrix(a: tm; s: string); var   i, j: integer; begin   writeln(s);   for i : = 1 to n do   begin       for j : = 1 to n do write(a[i, j]: 5);       writeln   end end; procedure displayvector(a: tv; s: string); var   i: integer; begin   writeln(s);   for i : = 1 to n do write(a[i]: 5);   writeln end; var   a, b: tm;   x, y, r, r1, r2: tv; begin   randomize;   initmatrix(a, -50, 50);   displaymatrix(a, 'матрица а');   initmatrix(b, -20, 65);   displaymatrix(b, 'матрица b');   initvector(x, -10, 14);   displayvector(x, 'вектор x');   initvector(y, 5, 40);   displayvector(y, 'вектор y');   prodmv(a, x, r1);   prodmv(b, y, r2);       { для отладки раскомментарить две нижележащие строчки }   { displayvector(r1,'вектор r1');       displayvector(r2,'вектор r2'); }   sumv(r1, r2, r);   displayvector(r, 'вектор результата') end. тестовое решение: матрица а   -19    27    30    25  -14     32  -35      9  -38    16   -39  -36    13    41  -37       7  -18    -8    35  -10       1  -48      1  -19    -2 матрица b   -15    62  -18    58    62     32    58    43      3    12     15    11    39  -20  -16     47  -10    24    16    55     -8    46    10      0    45 вектор x       2    -6    10      0    -3 вектор y     15    14    22    14    15 вектор результата   2131 2776 1096 2214 1725
pravovoimeridian
Электрический обогреватель 1 включенный электрический обогреватель нельзя оставлять возле процессора , так как он может перегрется и сгореть 2 включенный электрический обогреватель нельзя оставлять возле монитора , так как он может перегрется и сгореть 3 включенный электрический обогреватель нельзя оставлять возле проводов компьютера , так как они могут перегрется и случится короткое замыкание а то и 4 включенный электрический обогреватель нельзя оставлять возле компьютера , так как вы можете случайно его задеть и обжечся 5 нельзя вставлять в розетку и включать обогреватель в одну пилотку с компьютером , так как из за обогревателя может произойти резкий скачок тока и компьютер не выдержит 6 и нельзя оставлять включенным обогреватель возле компьютера так как вы можете его случайно задеть и он может упасть и сжечь ваш ковер а то и квартиру
btatarintsev
Вскобках - система счисления (сс) пример: 1001(2) - в двоичной системе счисления ^n - степень n - цифра например: 2^8 - два в восьмой степени. a=10 b=11 c=12 d=13 e=14 f=15 a)  111011011.0101(2) =  475.3125(10)111011011.0101(2)  = 1∙2^8+1∙2^7+1∙2^6+0∙2^5+1∙2^4+1∙2^3+0∙2^2+1∙2^1+1∙2^0+0∙2^-1+1∙2^-2+0∙2^-3+1∙2^-4  = 256+128+64+0+16+8+0+2+1+0+0.25+0+0.0625 = 475.3125(10) б) 442.67(8) =  290.859375(10)4∙8^2+4∙8^1+2∙8^0+6∙8^-1+7∙8^-2   = 256+32+2+0.75+0.109375 = 290.859375( 10) в) 1f5.b = 501.6875(10) 1f5.b16   = 1∙16^2+15∙16^1+5∙16^0+11∙16^-1   = 256+240+5+0.6875 = 501.6875( 10)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны две матрицы а(nxn) и b(nxn), а также два вектора х = (x1, xn) и y = (y1, y2, yn написать программу нахождения скалярного произведения (ах)*(ву).
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

konnovakat1
Надежда-Алексеевна82
Yuliya_Viktoriya316
myudanova631
Ludmila777020
mariy-y34
Кирилл_Гульницкий
and-syr
mokeevahelena
Vladimir
Irina-Tunyan
Елена-Семенова
борисовна Елена78
mistersoshnev354
Aksinya1036