Не очень понятно, длину двоичного кода одного символа или длину двоичного кода всех 33 символов, как бы записанных в ряд..
Ну да ладно, вычислим, сколько информации содержит 1 символ при мощности алфавита = 33:
33 = 2ˣ => минимальный x = 6
Значит один символ будет нести 6 бит информации, то есть длина двоичного кода для записи одного символа равна 6.
Если мы умножим 6 на количество символов, то получим количество информации, требуемое для записи 33 букв, т.е.:
6*33 = 198 бит
ответ: Длина двоичного кода одной буквы равна 6, а 33 букв - 198.
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, которая формирует массив из 15 случайных чисел принадлежащих промежутку [3, 33]. нечетные числа заменяет на 1, а остальные увеличивает на 3. на экран выводятся исходные и преобразованные значения
var
a: array [1..15] of integer; //массив из 15 целых чисел
i: integer;
begin
randomize;
write('исходный массив: ');
for i: = 1 to 15 do {заполняем массив случайными целыми числами в промежутке [3; 33] и распечатываем его}
begin
a[i]: = random(31) + 3;
write(a[i], ' ');
end;
writeln;
write('преобразованный массив: ');
for i: = 1 to 15 do {если элемент нечетный, то заменяем его на 1, иначе увеличивам его на 3 и распечатываем полученный массив}
begin
if a[i] mod 2 = 0 then a[i]: = 1
else a[i]: = a[i] + 3;
write(a[i], ' ');
end;
writeln; {переход на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}
end.
если все правильно, отметь решение как лучшее)