Vrpeshka
?>

А)дан фрагмент программы read (x); read (y); a: = (x-y)/2*x; write(a) write(x) его, скоратив число операторов б) что будет выведено на экран после ввполнение фрагмента программы: a : = 3; b : = 4; a : = 2*a+3*b b : = a/2*b write(c) в) составить программу, вычесляющую длинну окружности и площажь круга радиуса 4, 1 см

Информатика

Ответы

Fedorovich309

Логическое «ИЛИ» ложно только тогда, когда ложны оба высказывания. Преобразуем выражение: (число <= 50) ИЛИ (число чётное) и проверим все варианты ответа.

Истинно, поскольку истинны оба высказывания:

40, 42, 44, 46, 48, 50.

Истинно, поскольку истинно первое высказывание:

41, 43, 45, 47, 49 не больше 50.

Истинно, поскольку истинно второе высказывание:

52, 54, 56, 58, 60. — чётное.

Ложно, поскольку ложны оба высказывания:

51, 53, 55, 57, 59.

Складываем числа которые являются ложным высказыванием условия:

51 + 53 + 55 + 57 + 59 = 275

ответ: 275

qwert28027170

Відповідь:

#include <iostream>

#include <cstdlib>

#include <time.h>

using namespace std;

void randarr(int *B,int N){

for(int i = 0; i < N; i++){

  B[i] = rand() % 10 + 1;

}

}

void printarr(int *B,int N){

for(int i = 0; i < N; i++){

  cout << B[i] <<"\t";

 }

}

void expression(int *B,int N){

for(int i = 0; i < N; i++){

 B[i] += 1;

}

}

int main(){

srand(time(NULL));

setlocale(LC_ALL , "Ukrainian");

int N;

cout << "Введiть кiлькiсть елементiв массиву N: ";

cin >> N;

int *B = new int[N];

randarr(B,N);

printarr(B,N);

cout << "\nДодаємо 1 до кожного елемента массиву... " << endl;

 

expression(B,N);

printarr(B,N);    

   

   delete[] B;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

А)дан фрагмент программы read (x); read (y); a: = (x-y)/2*x; write(a) write(x) его, скоратив число операторов б) что будет выведено на экран после ввполнение фрагмента программы: a : = 3; b : = 4; a : = 2*a+3*b b : = a/2*b write(c) в) составить программу, вычесляющую длинну окружности и площажь круга радиуса 4, 1 см
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

abroskin2002
horina12
Ushakova Sakhno
yugraspets
yliana
Ruzalina_Svetlana1435
toxicfish
alekseev13602
гайсанов
Вячеславович-Дмитрий1694
Дмитрий192
vdm4275
MariyaKhanbalaeva585
appbiznessm
edvard-b