delfinmos
?>

Написать программу в паскале! задан целочисленный массив из 10 случайных целых чисел. выполнить сортировку элементов массива, стоящих на четных номерах по убыванию методом пузырька.

Информатика

Ответы

uttgroup
Const    b=10; var    a: array[1..b] of integer;     i, j, k: integer; begin randomize; write ('pervonachalnii massiv: ');   for i : = 1 to b do  begin    a[i] : = random(100);     write (a[i]: 4);   end;   writeln;   for i : = 1 to b-1 do    for j : = 1 to b-i do    if a[j] > a[j+1] then      begin        k : = a[j];         a[j] : = a[j+1];         a[j+1] : = k;         end;   write ('otsortirovannii massiv: ');   for i : = 1 to b do  begin    write (a[i]: 4);   end;   writeln; readln; end.
lika080489
Бесконечность – не предел! этот девиз из известного высказывания стива джобса как нельзя лучше отражает происходящее в настоящее время проникновение прогрессивных технологий в жизнь человека. современная предполагает, что в основе окружающей человека реальности лежит бесконечность. перед бесконечностью все равны и кибернетический суперинтеллект будущего и человек с его недостатками, всем есть экологическая ниша для жизни. будущее принадлежит не человеку и не роботу, а своеобразному кентавру – человеко-машинному комплексу. из выше сказанного тривиально следует команду назвать: кентавры.
rn3ay8
Изначально s = 60 цикл будет работать 6 раз первый проход цикла: k = 5, тогда s  =  60 - 5  = 55 второй проход цикла: k = 6 (т.к один проход уже сделан, и значение переменной k увеличилось на 1), тогда s = 55 - 6 = 49 третий проход цикла: k  =  7, тогда s = 49 - 7 = 42 четвертый проход цикла:   k = 8, тогда s = 42  -  8 = 34 пятый проход цикла: k = 9, тогда s = 34 - 9 = 25 шестой проход цикла: k = 10, тогда s = 25 - 10 = 15 окончательный ответ: значение переменной s после выполнения цикла = 15

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале! задан целочисленный массив из 10 случайных целых чисел. выполнить сортировку элементов массива, стоящих на четных номерах по убыванию методом пузырька.
Ваше имя (никнейм)*
Email*
Комментарий*