egorov
?>

Напишите программу, где я ввожу целостное число a и b, и если a делиться на b, то программа должна вывести divisible иначе not divisible. python

Информатика

Ответы

Yurevna991
//pascalabc.net//версия 3.3, сборка 1634 (14.02.2018) begin     var (n, k) : = readinteger2('n,k-> ');     var p : = arrgen(n, t -> t + 1);       var m : = new integer[k, n div k];     var sum : = p.sum div k;     for var i : = 0 to k - 1 do     begin       var m_sum : = sum;       m[i, 0] : = p[0]; m_sum : = m_sum - m[i, 0];       p : = p[1: ];       for var j : = 1 to (n div k) - 1 do       begin           if m_sum - p.last > 0 then begin m[i, j] : = p.max;   m_sum : = m_sum - p.max; p : = p[: p.indexmax]; end           else            begin             if p.where(t -> t = m_sum).count = 1 then m[i, j] : = m_sum;             p : = p.where(t -> t < > m_sum).toarray;           end;                                                           end;     end;       var t : = true;     for var i : = 0 to m.rowcount - 2 do       if (m.row(i).sum < > m.row(i + 1).sum) or (p.length < > 0) then begin t : = false; break; end;     if t then m.println else 0.println; end. пример(1):   n,k-> 8 2     1   8   7   2     3   6   5   4 пример(2):   n,k-> 6 3     1   6     2   5     3   4
ramco1972
Program ryazantsev; var n,k,i,b,sum: integer; begin readln(n,k); sum: =trunc((1+n)/2*n); //преобразование типа real к int, trunc можно безопасно использовать, т.к. сумма n членов арифметической последовательности целых чисел - всегда целое число if sum mod k < > 0 then writeln(0) else begin for i: =1 to k do begin b: =1; while b< n/k do begin write(i+b-1, ' ', n-i-b+2, ' '); b: =b+k end; writeln() end end; end. пример входных данных, при которых программа выведет ноль: 6 2 и ещё, должна быть оценена явно больше, чем на пять )

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, где я ввожу целостное число a и b, и если a делиться на b, то программа должна вывести divisible иначе not divisible. python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nikolaevich
bb495
Вячеславовна_Сагитович
slazurnaya
dima0218687
shchepinasm
dnikolay365
artemy682719
info7
Anatolevich_Kulikov1229
Rafigovich1267
TatiyanaBe20135263
apetrov13
mikchaylovaalex
stsnab