merzlikinairena
?>

Напишите программу, которая считывает количество символов в предложении, за исключением кавычек. для обозначения конца предложения используйте точку.си

Информатика

Ответы

evrotrastop64
#include "stdafx.h" #include < stdio.h> #include < windows.h> int main()       {       setconsolecp(1251);               setconsoleoutputcp(1251);     int const n=3; int mas[n][n]; int sum1, sum2; bool magik; for (int i=0;   i< n;   i++)       for (int j=0;   j< n;   j++)           {             printf("mas[%d][%d] = ",  i+1, j+1);             scanf("%d",& mas[  i  ][  j  ]);           } printf("\nвведенная матрица: \n");       for (int i=0;   i< n;   i++)           {               for (int j=0;   j< n;   j++)                         {                             printf("%d   ",mas[  i  ][  j  ]);                         }               printf("\n");           } sum1=0; sum2=0; for (int i = 0; i< n; i++)       {               sum1 += mas[  i  ][  i  ];             sum2 += mas[  i  ][  n-1-i  ];       } printf("сумма главной диагонали = %d\n",  sum1); printf("сумма побочной диагонали = %d\n",  sum2); magik = true; for (int i=0;   i< n;   i++)     {           if (sum1==sum2)               {                   sum2=0;                   for (int j=0;   j< n;   j++)                       {                           sum2 += mas[  i  ][  j  ];                       }                 } else  { magik=false; break; }       } if (magik==true)       {             for (int i=0;   i< n;   i++)                     {                     if (sum1==sum2)                           {                             sum2=0;                             for (int j=0;   j< n;   j++)                                 {                                     sum2 += mas[  j  ][  i  ];                                 }                           }                           else  { magik=false; break; }                   }         } if (magik==true)       printf("\nматрица является магическим квадратом\n");     else       printf("\nматрица не является магическим квадратом\n"); system("pause"); return 0; }
platonm777639
// pascalabc.net 3.0, сборка 1156 от 30.01.2016 begin   var n,m: integer;   read(n,m);   var a: array[,] of integer;   setlength(a,n,m);   for var i: =0 to n-1 do       for var j: =0 to m-1 do read(a[i,j]);   var k,r: integer;   read(k,r);   var p: =0; //будущий результат   foreach var x: integer in a do begin       var s: =0; var q: =x; var k1: =0;       while q< > 0 do begin           s: =s+(q mod 10); q: =q div 10; inc(k1)           end;       if (k1=k) and (s mod r = 0) then inc(p)       end;   writeln(p) end. тестовое решение: 5 5 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 2 3 5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая считывает количество символов в предложении, за исключением кавычек. для обозначения конца предложения используйте точку.си
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mariavayda88734
Викторович
yna21289
ashybasaida-33
textildlavas21
Nonstop788848
sochi-expert
sargisyan77
egorova90356684858370
Bi-1704
alfastore4
D.Yu. Polina1703
danya1509379
aprelevka
olgakuz00261
▲