Klyucharyova
?>

Заполните массив 11-ю случайными числами промежутка [-20; 10]. выведите его в строке. все элементы с нечетными значениями уменьшите в 3 раза, а остальные - увеличьте на 5. выведите новый массив

Информатика

Ответы

zorinka777

var a: array[1..11]of integer;

i: integer;

begin

randomize;

for i: =1 to 11 do a[i]: =random(31)-20;

for i: =1 to 11 do write(a[i],' ');

writeln;

for i: =1 to 11 do if a[i] mod 2< > 0 then a[i]: =a[i] div 3 else a[i]: =a[i]*5;

 

for i: =1 to 11 do write(a[i],' ');

end.

SVETLANAluiza1534
Код программы var       a: integer; function c(a: integer): integer; var       b: integer; begin       b : = 30;       a : = -a - 3 * b;             if a < b then               c : = b + 45       else               c : = b - 50; end; begin       for a : = 1000 downto -1000 do               if c(a) = -20 then begin                       writeln('a=', a, ' c(a)=', c(a));                       break;               end; end. вывод a=-120 c(a)=-20 аналитическое решение. видно что c: =b - 50 = 30 - 50 = -20 при a> =b -a-3*b> =b -a-3*30> =30-a-90> =30 -a> =120a< =-120
Taurus59707
//составить программу, которая после введённого с клавиатуры числа от 1 до 99 обозначает денежную единицу дописывающую слово "копейка" в правильной форме. begin var a : = readinteger; var c : string; assert(a > = 1); assert(a < = 99); case a of 1, 21, 31, 41, 51, 61, 71, 81, 91: c : = 'копейка'; 2..4, 22..24, 32..34, 42..44, 52..54, 62..64, 72..74, 82..84, 92..94: c : = 'копейки'; 5..20, 25..30, 35..40, 45..50, 55..60, 65..70, 75..80, 85..90, 95..100: c : = 'копеек'; end; writeln(a, ' ', c); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заполните массив 11-ю случайными числами промежутка [-20; 10]. выведите его в строке. все элементы с нечетными значениями уменьшите в 3 раза, а остальные - увеличьте на 5. выведите новый массив
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Владимирович_Ралина
Запишите и решите формулу в решить с
тахирович_Игорь581
Wlad967857
sotrudnik3
гайсанов
Краева
annino
Шеина
Lenamihluk50
Коробкова1437
slava-m-apt
yurick2071488
bufetkonfet53
Eduard Melikyan