marim1994361
?>

Даны длины а, в, с сторон некоторого треугольника. найти медианы треугольника, сторонами которого являются медианы исходного треугольника. pascal abc нужно написать программу, используя процедуру(ы) и функцию(ы , ! : )

Информатика

Ответы

citioil15
Type   num=double; { в этом месте можно сменить тип на иной } function legal(a,b,c: num): boolean;   { возвращает true, если из отрезков длиной a,b,c       можно построить треугольник } begin   legal: =(a+b> c) and (a+c> b) and (b+c> a) end; function med(a,b,c: num): num;   { возвращает длину медианы, проведенную к стороне а } begin   med: =sqrt(2*(sqr(b)+sqr((a))/2 end; procedure med3(a,b,c: num; var m1,m2,m3: num);   { возвращает длины m1,m2,m3 всех медиан треугольника,       построенного из отрезков длиной a,b,c.       при этом m1- длина медианы, проведенной к стороне а,       m2- дилна медианы,проведенной к стороне b и т.д.       если треугольник построить нельзя, m1=m2=m3=0 } begin   if legal(a,b,c) then   begin m1: =med(a,b,c); m2: =med(b,a,c); m3: =med(c,a,b) end   else begin m1: =0; m2: =0; m3: =0 end end; { основная программа } var   a,b,c,m1,m2,m3: num; begin   write('введите длины сторон треугольника: '); readln(a,b,c);   med3(a,b,c,m1,m2,m3);   if m1> 0 then begin       med3(m1,m2,m3,m1,m2,m3);       if m1> 0 then writeln('длины медиан: ',m1,', ',m2,', ',m3)       else writeln('из полученных медиан нельзя построить треугольник.')       end   else       writeln('невозможно построить треугольник с такими сторонами.') end. тестовое решение: введите длины сторон треугольника: 14.3 18.9 8.6 длины медиан: 10.725, 14.175, 6.45
sharovaeln6

почему бы самому не воспользоваться калькулятором?

раздел программист

bin

10111+101 = 1 1100

110011+1110 =   100 0001

1111(умножить)11 =   10 1101

100011-110 = 1 1101

1011(умножить)101 =   11 0111

101100-101 = 10 0111

а вообще-то интересно самому прочитать разок внимательно как выстроен двоичный код,

легко и интересно, да и быстро будет в уме расписывать решения; самому человеку станет приятен процесс получения правильных решений (увлекательно)

+ гимнастика для нейронных связей мозга/память/сообразительность/

elozinskaya

здравый смысл говорит, что к k-ичным при k > = 17.

в шестнадцатеричной последняя цифра f, за буквой f в латинском алфавите следует буква g, которая у вас использована. буквы, которые в алфавите следуют после g, у вас не использованы.

однако, отмечу, что система счисления - всего лишь метод записи чисел, и даже позиционность не накладывает ограничений на то, какие значки там играют роль цифр.

вы можете взять, например, взять вот так множество цифр:

d, 1, 2, 3, 0, g, 6,

использовать его в семиричной системе счисления и долго радоваться, что "обманули" учителя, за что он вам по доброте душевной вкатил двойку.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны длины а, в, с сторон некоторого треугольника. найти медианы треугольника, сторонами которого являются медианы исходного треугольника. pascal abc нужно написать программу, используя процедуру(ы) и функцию(ы , ! : )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lenacari
Alenachernika9111
NIKOLAEVNA
irina611901
doorhan42n6868
Семеновна-Павел
Юлия-Ольга1313
yurievaalxndra55
Powerbasses5521
Jannadon77
Anna Artem
ldfenix87
nestruev
remontsalarievo2
motor2218