ainetdinovsnab
?>

Составьте программу человека и ответ компьютера человека ответ компьютера здорово добрый день салют салют салют салют здравия желаю вольно

Информатика

Ответы

banketvoshod
Program  privet; var  s:   string; begin writeln ('введите '); readln (s); if  s=''  then writeln (''); if (s='') or (s='здорово')  then writeln (''); if (s='добрый день')  or (s='')  or (s='салют')  then writeln ('салют'); if s='здравия  желаю' then writeln ('вольно'); end.
grafffmc
Язык программирования имеет какой-то официальный стандарт. от которого можно в той или иной степени отклоняться. а иногда и нужно, чтобы язык не умер, перестав удовлетворять современным технологиям программирования. посмотрим на примере такого распространенного языка, как паскаль. никлаус вирт описал паскаль в 1970 году. будучи соавтором разработки языка algol-68, он взял за основу алголоподобный синтаксис, в то время считавшийся наиболее удачным. первая реализация паскаля была сделана под конкретную машину и носила отпечаток требований её операционной системы. сюда, например, относится требование, чтобы программа начиналась с оператора program, содержащего указания на файлы ввода и вывода. с распространением паскаля на другие машины нужда в этих указаниях отпала, но некоторые школьные учителя, даже не зная о причинах, до сих пор уверяют учеников, что программа должна начинаться именно с program! шло время, программирование не стояло на месте. возникали новые языки, создавались новые технологии, компьютеры проникали во все новые области. появились персональные компьютеры. с этого момента паскаль получил вторую жизнь. понятный, быстро изучаемый и компилируемый в компактный код, это был отличный язык для "персоналок" с объемом памяти в 640 кбайт. но это был уже не тот, прежний паскаль. для работы с персоналками понадобилось его существенно дополнить. так возникла интегрированная система (среда) программирования turbo pascal. именно система, потому что она включала компилятор с диалекта (т.е. с некоторой конкретной реализации) языка паскаль, текстовый редактор, систему отладки, систему справок и поддержку выполнения программы. впоследствии возникли другие диалекты паскаля, такие как входной язык системы borland delphi, язык free pascal, язык системы pascal abc и наконец, среда программирования pascalabc.net, которая далеко ушла от паскаля никлауса вирта, вобрав в себя лучшие черты и средства языков c#, python и haskell.
markitandl
1. определяем мощность алфавита (количество символов в нем). 25 букв и 10 цифр составляют 35 различных знаков алфавита. 2. найдем объем памяти, занимаемый одним номером. при кодировании " одинаковым и минимально возможным количеством битов" для записи кода одного из 35 символов потребуется 6 бит, поскольку2⁵< 35< 2⁶ и 5 бит будет недостаточно. тогда семисимвольный номер займет 7×6=42 бита. но номера кодируются так, что они занимают целое количество байт. в байте 8 бит, поэтому 42 бита займут 42/8 ≈ 6 байт.3. найдем объем памяти под 80 номеров80×6=480 байт.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу человека и ответ компьютера человека ответ компьютера здорово добрый день салют салют салют салют здравия желаю вольно
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sleek73
juli19657
dvbbdv4
Anatolevich-sergeevna
yfetyukov
achernakov
Цветкова
yurassolo747
beliaeva2
skzzkt
Tuzov
Anastasiamoscow80
mez-omts-d5
Panfilov_Anna
▲