alex091177443
?>

Составить программу на языке с, которая по данному числу (1-12) выводит название соответствующего ему месяца

Информатика

Ответы

ntyremsk1

char months[][4]={"jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec"}; unsigned int num; scanf("%u",& num); if(num< =12) printf("%s",months[num-1]); else printf("invalid number");

nelli-bi6
Обозначим x1 < > x2 через y1, x3 < > x4 через y2 и т.д. получим систему y1 or y2 = 1 y2 or y3 = 1 y3 or y4 = 1 y4 or y5 = 1 количество наборов y1..y5, удовлетворяющих данным условиям - 13. набор будет являться решением системы, если в нем нет идущих подряд нулей - тогда в каждой из пар (y1,y2), (y2,y3), (y3,y4), (y4,y5) будет хотя бы одна единица, т.е. все операции or также будут давать единицу. можно перебрать такие наборы вручную: 11111, 11110, 11101, 11011, 11010, 10111, 10110, 10101, 01111, 01110, 01101, 01011, 01010 либо воспользоваться формулой f(n) = f(n-1) + f(n-2), f(0) = 1, f(1) = 2; тогда f(5) = 13. здесь f(n) - количество последовательностей длины n, где нет двух идущих подряд нулей - их можно разбить на две группы, в одной на первой позиции стоит 1 (их f(n-1), т.к. оставшиеся элементы выбираются в соответствии с тем же правилом), в другой - 0 (их f(n-2), т.к. раз в последовательности нет двух идущих подряд нулей, на второй позиции обязана стоять единица). далее каждому значению y соответствуют две пары возможных значений x-ов. т.е., например, y1 = 1 соответствуют x1 = 1, x2 = 0 и x1 = 0, x2 = 1, а y1 = 0 соответствуют x1 = 0, x2 = 0 и x1 = 1, x2 = 1. в наборе y1..y5 каждому y соответствует два набора x -> всему набору y соответствует 2^5 = 32 набора x. всего 13 наборов y -> 13 * 32 = 416 наборов x. ответ: 416
Abespal
Мы знаем что у нас нечетное число букв, причем что нечетность приходится на букву б (7) все палиндромы длиной во все буквы тогда каждый палинром  имеет такую схему: [некий набор альфа]б[альфа в обратном порядке] разных альф может быть тоже 35 и состоит из половины букв ч и (7-1)/2 = 3 букв б обозначим все колво букв ч = 2x, а половину - х значит у нас тут перестановки с повторениями, колво которых 35 35 = (x+3)! / (x! 3! ) 35 * 3! = (x+3)(x+2)(x+1) 7 * 5 * 3 * 2 = (x+3)(x+2)(x+1) можно представить так 7 * 6 * 5 = (x+3)(x+2)(x+1) очевидно что 7 = х + 3 т.е. х = 4 а букв ч = 2х = 2 * 4 = 8 надеюсь понятно

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке с, которая по данному числу (1-12) выводит название соответствующего ему месяца
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

terma-msk1
elena-vlad822828
olyaartemenko
anatolevich1931
fil-vasilij90
e-s-i-k
natapetrova20017
zdanovich90764
verich
karpovaveronika196
Apresov
yrgenson2011801
Оксана759
tanu0618
alvas12828646