Devaunka40
?>

Написать программу в pascal'e. если матрица квадратная, то поменять местами минимальный и максимальный элементы побочной диагонали. в противном случае-заменить элементы четных строк нулями.

Информатика

Ответы

sargisyan
Const   nm = 20;   nn = 20; var   a: array[1..nm, 1..nn] of integer;   i, j, m, n, k, imin, imax, nmin, nmax: integer; begin   write('введите число строк и столбцов матрицы: ');   readln(m, n);   randomize;   writeln('исходная матрица');   for i : = 1 to m do   begin       for j : = 1 to n do       begin           a[i, j] : = random(101) - 50;           write(a[i, j]: 4)       end;       writeln   end;   if m = n then begin       imax : = 1; imin : = 1; nmax : = a[1, n]; nmin : = nmax;       for i : = 2 to n do       begin           k : = a[i, n - i + 1];           if nmax < k then begin imax : = i; nmax : = k end;           if nmin > k then begin imin : = i; nmin : = k end       end;       a[imax, n - imax + 1] : = nmin; a[imin, n - imin + 1] : = nmax   end   else begin       i : = 2;       while i < = m do       begin           for j : = 1 to n do a[i, j] : = 0;           i : = i + 2       end;   end;   writeln('матрица-результат');   for i : = 1 to m do   begin       for j : = 1 to n do write(a[i, j]: 4);       writeln   end;   writeln end. тестовые решения: введите число строк и столбцов матрицы: 5 5 исходная матрица   29  40 -24  34  16   32 -45    9 -10  27   -45  30 -50 -24 -50   15  33    3  12  36   46 -46    0    2  43 матрица-результат   29  40 -24  34  16   32 -45    9 -10  27   -45  30  46 -24 -50   15  33    3  12  36   -50 -46    0    2  43 введите число строк и столбцов матрицы: 5 6 исходная матрица   27    3 -18  36 -48  22   -27 -19    4 -36 -50  -9   -48 -25    9 -36  10  26   10 -22 -15 -40 -42  38   -31  32  41 -17 -26  22 матрица-результат   27    3 -18  36 -48  22     0    0    0    0    0    0   -48 -25    9 -36  10  26     0    0    0    0    0    0   -31  32  41 -17 -26  22
yurogov61
// pascalabc.net 3.3, сборка 1549 от 17.10.2017 // внимание! если программа не работает, обновите версию! begin   var r: =range(100,1000);   writeln('сумма четных: ',r.where(x-> x.iseven).sum);   writeln('произведение нечетных: ',           r.where(x-> x.isodd).aggregate(biginteger(,y)-> x*y)) end. результат сумма четных: 248050 произведение нечетных: 36966544481545882391823230067805385433230065368829576574915631961875951438749314875520891958773465683198309929571713227368698968335498279329362186811130459340459701708143628528300666430241499963363995156875472920823879073796270530674091365457301367694608396460427864525856348256854709381753098272866558646536629626322781887765489939455189437187612366035802205337138797639784505362746964525946343706655765053639253274426077913592271079783658672906924798929301517243147811305368104203869922649498420017010079861449087671086945458864075701800348571856363660191891005745473487285185093263826285985161291672009840401500648116978749473368664914039649974635642316727953613512087059513022266150683907968562889468475751462634414790601916842157202699257750637933476610759209266207736659346632336154863491811161547515391373090783158239924403943495793328563207072814564054863234093687597907376741512012744430337566475185020879095658879920498365311358232252688878619532793045747038932448911025039177711271956296398164256480905110102487991832871736322981910580412208741937654427051439114361588088330674072568693330290186189385005707253104742148887065855866777951156097027659674751631779798799470881931483745574951171875
vshumilov

Объяснение:

Автоматиза́ция произво́дства — это процесс в развитии машинного производства, при котором функции управления и контроля, ранее выполнявшиеся человеком, передаются приборам и автоматическим устройствам[1]. Введение автоматизации на производстве позволяет значительно повысить производительность труда, обеспечить стабильное качество выпускаемой продукции, сократить долю рабочих, занятых в различных сферах производства.

До внедрения средств автоматизации, замещение физического труда происходило посредством механизации основных и вс операций производственного процесса. Интеллектуальный труд долгое время оставался не механизированным (ручным). В настоящее время операции физического и интеллектуального труда, поддающиеся формализации, становятся объектом механизации и автоматизации. В качестве характеристики измерения может выступать понятие уровня (степени) автоматизации.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в pascal'e. если матрица квадратная, то поменять местами минимальный и максимальный элементы побочной диагонали. в противном случае-заменить элементы четных строк нулями.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

themolodoy
superkiosk249
Nazaruk_Kodochigov
teregorka1977205
asker45967
Gennadevna-Darya1216
asemchenko
Yuliya
rabchek145200614
zodgener
magazintrofey
valera850515
iriska-669
tyrenumberone
▲