elyashatdinova
?>

Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов; 4) заменить числом 5 элементы, стоящие на четных местах, и числом 0 - элементы, стоящие на нечетных местах, вывести в строку получившийся массив.

Информатика

Ответы

galtig83
Program t1; const   j = 18 var   n,j, i, s,s1: integer;   mas: array [1..j] of integer; begin       randomize;       writeln ('сгенерированный масив: ');       for i : = 1 to j do       begin           mas[i] : = random (70) - 35;           write (mas[i]);       end;             s: = 0; s1: =0;       for i : = 1 to j do       begin           if (i mod 2 =0) then s : = s+mas[i];                           //сумма четных элементов           if (mas[i] > = 0) then s1 : = s1 + mas[i];             //сумма неотрицательных элементов       end;           writeln ('среднее арифметическое четных элементов:   ', s/18);       writeln ('сумма неотрицательных элементов:   ', s1);       writeln ('массив после замены элементов:   ');               for i : = 1 to j do       begin                if (i mod 2 =0) then mas[i] : = 5 else mas[i] : = 0;           write (mas[i]);         end;               end; end.
zuzman601
Const     m = 4;     n = 4; var     a: array[1..m,1..n] of integer;     i,j: integer; begin writeln('массив: '); for i: = 1 to m do       begin       for j: = 1 to n do               begin               if (i+j) mod 2 = 0 then a[i,j]: =i*j               else a[i,j]: =i+j;               write(a[i,j]: 3,' ')               end;             writeln       end; end.
demochkoo
Var n,d: integer; begin write('введите месяц : '); readln(n); write('введите день : '); readln(d); n: =n mod 12;   case n mod 12 of   1: if d< =20 then writeln('козерок') else writeln('водолей');   2: if d< =21 then writeln('водолей') else writeln('рыба');   3: if d< =21 then writeln('рыба')    else writeln('овен');   4: if d< =21 then writeln('овен')    else writeln('телец');   5: if d< =21 then writeln('телец')    else writeln('близницы');   6: if d< =22 then writeln('близницы')    else writeln('рак');   7: if d< =23 then writeln('рак')    else writeln('лев');   8: if d< =24 then writeln('лев')    else writeln('дева');   9: if d< =24 then writeln('дева')    else writeln('весы');   10: if d< =24 then writeln('весы')    else writeln('скорпион');   11: if d< =23 then writeln('скорпион')    else writeln('стрелец');   12: if d< =22 then writeln('стрелец')    else writeln('козерок'); end; end. //без if вряд ли удаться обойтись(+ я не учитывал високосный год и кратный 100 и 400)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу: 1) сформировать массив из 18 целых случайных чисел из [-35; 35], вывести исходный массив в строку; 2) найти среднее арифметическое всех четных элементов массива; 3) найти сумму неотрицательных элементов; 4) заменить числом 5 элементы, стоящие на четных местах, и числом 0 - элементы, стоящие на нечетных местах, вывести в строку получившийся массив.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

missimeri
olechka197835
hobpack
armsam76
arutchevben64
александр496
Владимир-Денисович1080
uzunanna19922488
nastyakrokhina87
Shtorm-Shoe
Dmitrychekov9
Narine natalya
Никита227
smakarov76
Геннадьевич-Тимофеева158
▲