Шиморянов Мария1866
?>

Составить программу, которая спрашивает: "кто это, кошка или собака? ". в зависимости от ответа ("к" или "с"), печатает на экране: "мяу-мяу! " или "гав-гав! ". , прошу

Информатика

Ответы

ellyb106786
// f# open system; [< entrypoint> ] let main argv =     let rec getresult _ =         let answer = console.readkey(true);         match answer.keychar with             | 'к' | 'к' -> "мяу-мяу! "             | 'с' | 'с' -> "гав-гав! "             | _ -> (getresult null)     printf "это кошка или собака? \n"     printf "%s" (getresult null)     0
rezh2009766
//pascal var    x: char; begin   writeln('кто это, кошка или собака? ');   readln(x);   if x = 'к' then   writeln('мяу-мяу! ');   if x = 'c' then   writeln('гав-гав! '); end.
Baidina
Var   i,d,dmin,dmax,kmax,imin,imax: integer;   n: longint; begin   write('введите натуральное число n: '); read(n);   dmin: =10; dmax: =-1; {больше большего и меньше меньшего}   i: =0;   repeat       d: =n mod 10; n: =n div 10; inc(i);       if dmax< d then begin dmax: =d; kmax: =1; imax: =i end       else if dmax=d then inc(kmax);       if dmin> d then begin dmin: =d; imin: =i end   until n=0;   writeln('минимальная цифра - ',dmin,' находится в разряде ',imin,'; ');   writeln('максимальная цифра - ',dmax,' находится в разряде ',imax,'; ');   writeln('сумма максимальной и минимальной цифры - ',dmin+dmax,'; ');   writeln('максимальная цифра встречается ',kmax,' раз(а); ');   write('минимальная цифра - ');   if (dmin mod 2)=0 then writeln('четная.')   else writeln('нечетная.') end. тестовое решение: введите натуральное число n: 388456 минимальная цифра - 3 находится в разряде 6; максимальная цифра - 8 находится в разряде 4; сумма максимальной и минимальной цифры - 11; максимальная цифра встречается 2 раз(а); минимальная цифра - нечетная.
jenko87
Program prog; uses crt; var n,k,min,max,x,i,s: integer; begin clrscr; write('введите натуральное число n: '); readln(n); x: =n; s: =1; writeln; min: =9; while x> 0 do begin         if x mod 10 > max then         begin         max: =x mod 10;     k: =s;         end;         if x mod 10 < min then         begin         min: =x mod 10;   i: =s;         end; x: = x div 10; s: =s+1 end; writeln('минимальная цифра - ',min,', находится в разряде ',i,'; '); writeln('максимальная цифра - ',max,', находится в разряде ',k,'; '); k: =0; writeln('сумма максимальной и минимальной цифры - ',min+max,'; '); while n> 0 do begin         if n mod 10 = max then         k: =k+1; n: =n div 10; end; writeln('максимальная цифра встречается ',k,' раз; '); if min mod 2 = 0 then  writeln('минимальная цифра - четная.') else  writeln('минимальная цифра - нечетная.'); end.         

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая спрашивает: "кто это, кошка или собака? ". в зависимости от ответа ("к" или "с"), печатает на экране: "мяу-мяу! " или "гав-гав! ". , прошу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

o-lala88387
dg9792794674
zu87zu87
gumirovane2294
kozak8824
merung
legezin
danielianruz
re-art
klykovav672
myataplatinumb348
YaroslavSerganYS5
smartschoolfili6
irnik65
tatk00
▲