Uses crt; var a, b, temp, i, s: integer; begin clrscr; write (' a = '); readln(a); write (' b = '); readln(b); s: =0; i: =a; while i< =b do begin if (i mod 2 = 0) then s: =s+i; i: =i+1; end; writeln(' s = ', s); readln; end.
tat72220525
21.09.2022
Var a,b,i,sum: integer; begin write ('введите границы интервала: '); read (a,b); for i: = a to b do if i mod 2 = 0 then sum: =sum + i; writeln ('сумма четных чисел в интервале от а до б = ',sum); end.
fursov-da
21.09.2022
Анализируем высказывания и убираем из таблицы строки, которые не подходят. если будет дождь, то будет пасмурно и безветренно - то есть, если дождь=1, то пасмурно=1 а ветер=0 из последних 4 строк, где д=1 остаётся только одна строка - предпоследняя, она и соответствует этому высказыванию, остальные, где д=1 противоречат 1 высказыванию д п в 0 0 0 0 0 1 0 1 0 0 1 1 1 0 0 1 0 1 1 1 0 1 1 1 теперь для оставшейся таблицы анализируем второе высказывание: если не будет ветра, то будет пасмурная погода без дождя ищем строки, где в=0, там должно быть п=1 и д=0: строки 1, 3, 5 из них подходит только третья строка, 1 и последнюю выкидываем. д п в 0 0 0 0 0 1 0 1 0 0 1 1 1 1 0 и наконец, для оставшихся трёх строк проверяем если будет пасмурная погода, то будет дождь и не будет ветра то есть, ищем, где п=1, там должно быть д=1 и в=0 д п в 0 0 1 0 1 00 1 1 ответ: будет ясно, без дождя, но ветрено
stailwomen31
21.09.2022
Количество информации определяется величиной, показывающей насколько уменьшилось наше незнание в вопросе. 1. если на светофоре горит желтый свет и мы не знаем, какой свет горел на нем до желтого, то возможны два исхода - зеленый свет и красный свет. какой бы из них потом не загорелся, мы получим выбор 1 из 2 возможных. а этому соответствует один бит информации. 2. если на светофоре горит красный свет и это "нормальный светофор", то мы знаем, что после красного света всегда следует желтый. поэтому при зажигании желтого света наше незнание не меняется, следовательно, мы получаем ноль бит информации.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу! найти сумму чётных чисел в интервале от а до в ( а и в - натуральные числа, а< в