Vs1377
?>

По языку паскаля, завтра уже сдать надо. 1) напишите программу, которая выводит код введенного пользователем символа. программа должна завершать свою работу в результате ввода, например точки. 2)напишите программу, которая выводит на экран первую часть таблицы кодировки символов (от 0 до 127 таблица должна состоять из восьми колонок и шестнадцати строк. в первой колонке должны быть символы с кодом от 0 до 15, во второй от 16 до 31 и т.д.

Информатика

Ответы

rkorneev19061
1: program znan1; uses crt; var a: char; begin clrscr; readln(a); while a< > '.' do begin writeln(ord(a)); readln(a); end; end.2 : program znan2; uses crt; var i,j: integer; beginfor i: =1 to 16 dobeginfor j: =1 to 8 dobeginwrite((i*j-1): 5,'-',chr(i*j-1)); end; writeln; end; readln; end.
juliavovo

program help; uses crt; const n = 10; (* размер массива *)var a : array[1..n] of integer; (* массив с числами *) i : integer; beginrandomize; clrscr; writeln('массив: '); for i : = 1 to n do begin a[i] : = random(601) - 300; (* заполняем рандомными числами *) writeln('a[', i, '] = ', a[i]); (* выводим на экран *) if (a[i] mod 3 = 0) and (a[i] mod 5 < > 0) then a[i] : = 0; (* обнуляем числа кратные 3 и не кратные 5 *) end; writeln('массив после изменения: '); for i : = 1 to n do writeln('a[', i, '] = ', a[i]); (* выводим на экран *)end.

Posadskii-Sergeevna

1) не достаточно информации2)program help1; uses crt; var a : array[1..3, 1..3] of integer; i, j, m : integer; beginclrscr; for i : = 1 to 3 do for j : = 1 to 3 do begin write('введи a[', i, ', ', j, ']: '); readln(a[i, j]); end; if a[1, 1] > 0 then m : = 4; if a[1, 1] < 0 then m : = 7; for i : = 1 to 3 do for j : = 1 to 3 do a[i, j] : = a[i, j] * m; end.3)program help2; uses crt; var s : string; n, i : byte; beginclrscr; write('введи строку: '); readln(s); n : = 0; for i : = 1 to length(s) do if s[i] = '5' then inc(n); write('цифра 5 встречается ', n, ' раз'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

По языку паскаля, завтра уже сдать надо. 1) напишите программу, которая выводит код введенного пользователем символа. программа должна завершать свою работу в результате ввода, например точки. 2)напишите программу, которая выводит на экран первую часть таблицы кодировки символов (от 0 до 127 таблица должна состоять из восьми колонок и шестнадцати строк. в первой колонке должны быть символы с кодом от 0 до 15, во второй от 16 до 31 и т.д.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kzhgutova
foto5113161
jamaltreid
saljagindima
Vladimirovna-Ignatenko1890
Иванникова736
Liliya-buc
ledlenta751
platonovkosty
smokestylemos
jaksonj326
rinan2013
Марина
fil-vasilij90
Salkinserg