Anastasiya Yevseeva948
?>

Составить программу вычисления объема цилиндра и конуса, которые имеют одинаковую высоту h и одинаковый радиус основания r (написать в паскале)

Информатика

Ответы

soa8690
Пусть V1 - объем цилиндра, а V2 - объем конуса, тогда:
\displaystyle V_1= \pi R^2h \\ V_2= \frac{1}{3} \pi R^2h= \frac{1}{3}V_1

const
  pi=3.14;
var
  V1,V2,R,h:real;
begin
  Write('Введите радиус и высоту: '); Read(R,h);
  V1:=pi*sqr(R)*h; V2:=V1/3;
  Writeln('Объем цилиндра ',V1:0:5,', объем конуса ',V2:0:5)
end.

Тестовое решение:
Введите радиус и высоту: 5.5 12.81
Объем цилиндра 1216.75785, объем конуса 405.58595
alicia179
1. 4 шага:
          35        56
1)       35        21
2)       14        21
3)       14         7
4)        7          7

2. Кораблик (см. фото)

3. 

Исходная цепочка                ЛОМ
         1-й шаг                         ЛОМ
         2-й шаг                         ЛОММОЛ
         3-й шаг                         ЛОММОЛН
         4-й шаг                         ЛОММОЛН
         5-й шаг                         ЛОММОЛННЛОММОЛ
         6-й шаг                         ЛОММОЛННЛОММОЛО
         Результат                     ЛОММОЛННЛОММОЛО
Количество букв «О»           5

4.

Исходная цепочка            КОЛ
        1-й шаг                      Л
        2-й шаг                      ЛЛО
        3-й шаг                      ЛЛОК
       Результат                   ЛЛОК

5.

Номер строки          Строка
          1                          1
          2                         21
          3                        312
          4                       4213
          5                      53124
          6                     642135
..............
9-я строка будет оканчиваться на четные цифры от 8 вниз 2468
1. имеются две кучки фишек. за один шаг исполнитель нод из кучки, содержащей больше фишек, убирает с
shalunovroman
1шаг алгоритма.
а) записывается исходная цепочка символов, после нее записывается исходная цепочка символов в обратном порядке
КОМ+МОК = КОММОК
б) затем записывается буква, следующая в русском алфавите за той буквой, которая в исходной цепочке стояла на последнем месте
(за буквой М в русском алфавите следует буква Н)
КОММОК+Н = КОММОКН
2 шаг алгоритма.
а) записывается исходная цепочка символов, после нее записывается исходная цепочка символов в обратном порядке
КОММОКН+НКОММОК = КОММОКННКОММОК
б) затем записывается буква, следующая в русском алфавите за той буквой, которая в исходной цепочке стояла на последнем месте
(за буквой Н в русском алфавите следует буква О)
КОММОКННКОММОК+О = КОММОКННКОММОКО
ответ: количество букв О в полученной последовательности = 5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления объема цилиндра и конуса, которые имеют одинаковую высоту h и одинаковый радиус основания r (написать в паскале)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kuchino09
alenchik19938823
monenko
sergeevna
oleonov
Vadim443
kirycha-2000719
prostopo4ta29
Константин Андрей
marat7
Olga1233
Dampil
Барскова1943
dddandmvd5210
Александрович