Манько_Панферов
?>

25 ! "сообщение" по теме динамика на языке python в сообщении, состоящем из одних букв и пробелов, каждую букву заменили её порядковым номером в алфавите (а - 1, б - 2, я - 33), а пробел - нулем. требуется по заданной последовательности цифр найти количество исходных сообщений, из которых она могла получиться. входные данные в первой строке содержится последовательность цифр. цифр не более 100. выходные данные вывести одно число. примеры входные данные 80946 выходные данные 1 входные данные 21705 выходные данные 3

Информатика

Ответы

lescha-77766
Небольшой такой класс на 15 учащихся

const
  n = 15;

var
  a: array [1..n] of integer;
  i, min, max: integer;

begin
  max := 150;min := 190;
  for i := 1 to n do
  begin
    a[i] := random(41) + 150;
    if a[i] > max then max := a[i];
    if a[i] < min then min := a[i];
    write(a[i], ' ');
  end;
  writeln;
  writeln('max = ', max, ' min = ', min);
  for i := 1 to n do
  begin
    write('Рост ', i:3, ' ученика ', a[i]:4, ' на ', (a[i] - min):4, ' больше мин. и ');
    writeln(' на ', (max - a[i]):4, ' меньше макс');
  end;
 
end.

Тестовое решение:
184 168 184 183 184 180 178 168 161 152 178 190 178 176 180
max = 190 min = 152
Рост   1 ученика  184 на   32 больше мин. и  на    6 меньше макс
Рост   2 ученика  168 на   16 больше мин. и  на   22 меньше макс
Рост   3 ученика  184 на   32 больше мин. и  на    6 меньше макс
Рост   4 ученика  183 на   31 больше мин. и  на    7 меньше макс
Рост   5 ученика  184 на   32 больше мин. и  на    6 меньше макс
Рост   6 ученика  180 на   28 больше мин. и  на   10 меньше макс
Рост   7 ученика  178 на   26 больше мин. и  на   12 меньше макс
Рост   8 ученика  168 на   16 больше мин. и  на   22 меньше макс
Рост   9 ученика  161 на    9 больше мин. и  на   29 меньше макс
Рост  10 ученика  152 на    0 больше мин. и  на   38 меньше макс
Рост  11 ученика  178 на   26 больше мин. и  на   12 меньше макс
Рост  12 ученика  190 на   38 больше мин. и  на    0 меньше макс
Рост  13 ученика  178 на   26 больше мин. и  на   12 меньше макс
Рост  14 ученика  176 на   24 больше мин. и  на   14 меньше макс
Рост  15 ученика  180 на   28 больше мин. и  на   10 меньше макс
tanya62soldatova72
Const n=3; m=4;
var a:array[1..n,1..m] of integer;
i,j:integer;
begin
for i:=1 to n do
 for j:=1 to m do
  begin
   write('a[',i,',',j,'] =');
   readln(a[i,j]);
  end;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do write(a[i,j]:4);
 writeln;
 end;
for i:=1 to n do
 for j:=1 to m do
   if a[i,j] mod 2 = 0 then a[i,j]:=a[i,j] div 2; 
writeln('Полученный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do write(a[i,j]:4);
 writeln;
 end;
end.

Пример:
a[1,1] =45
a[1,2] =32
a[1,3] =76
a[1,4] =12
a[2,1] =85
a[2,2] =19
a[2,3] =35
a[2,4] =74
a[3,1] =65
a[3,2] =37
a[3,3] =83
a[3,4] =67
Исходный массив:
  45  32  76  12
  85  19  35  74
  65  37  83  67
Полученный массив:
  45  16  38   6
  85  19  35  37
  65  37  83  67

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

25 ! "сообщение" по теме динамика на языке python в сообщении, состоящем из одних букв и пробелов, каждую букву заменили её порядковым номером в алфавите (а - 1, б - 2, я - 33), а пробел - нулем. требуется по заданной последовательности цифр найти количество исходных сообщений, из которых она могла получиться. входные данные в первой строке содержится последовательность цифр. цифр не более 100. выходные данные вывести одно число. примеры входные данные 80946 выходные данные 1 входные данные 21705 выходные данные 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Mbkozlov6
ganzashop
annademidova-74
imosal
shilinmikhaillg
sn009
Natalya1895
Татьяна902
betepah
pbttehnology
jaksonj326
Ignateva737
alex091177443
e-s-i-k
tarhan1221