AnzhelikaSlabii1705
?>

1)составьте программу, которая выводит на экран таблицу перевода а, а+1, а+ минут в секунды. границы а и б вводятся с клавиатуры. введите границы : 12 18 12 мин = 720 18 мин =1080 сек 2)составить программу для решения следующей : начав тренировки, спортсмен в первый день пробежал 10 км. каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. какой суммарный путь пробежит спортсмен за n дней? ( все в паскале)

Информатика

Ответы

Коваленко
1.

program xopow1;
   uses   crt;
   var  
 a, b, Sek: integer;  
begin  
writeln('Введите границы:');  
repeat    
readln(a, b);  
until b >= a;  
 clrscr;  
for a := a to b do
    begin    
Sek := a * 60;    
writeln(a, ' мин. = ', sek, ' сек.')  
end
end.

2.

program xopow2;
  uses crt; 
Var
 z:integer;
 f,x,y:real; 
Begin 
clrscr; 
Writeln;
X:=10000;
Y:=(x/100)*10;
for z:=1 to 7 do 
 Begin 
X:=x+y; 
Writeln(Z,' -й день тренировок спортсмен пробежал ',X:3:2,' Км.'); 
End; 
Writeln('Нажмите Enter...'); 
Readln; 
end.
Vasilevna_Utenkova651
1) Program n1; 
var n,i:integer; 
t:array[1..100] of real; 
a,b:real; 
begin 
readln(n); 
readln(a); 
readln(b); 
for i:=1 to n do 
begin 
t[i]:=(b-a)/n; 
write(t[i],'  '); 
end; 
end.
2) Program n1; 
var a:array[1..100] of integer; 
n,i:integer; 
k:real; 
begin 
read(n); 
k:=0; 
for i:=1 to n do 
read(a[i]); 
for i:=1 to n do 
if a[i] mod 2 <> 0 then 
k:=k+1; 
writeln; 
writeln('кол-во нечет. чисел равно ',k,''); 
end.
6) Program n1; 
var a:array[1..100] of real; 
i,n:integer; 
s,sr:real; 
begin 
read(n); 
for i:=1 to n do 
read(a[i]); 
s:=0; 
sr:=0; 
for i:=1 to n do 
s:=s+a[i]; 
sr:=s/n; 
writeln('сред. арифметическое равно ',sr,''); 
end.
7)  Program n1; 
var a:array[1..100] of real; 
i,n:integer; 
min,max:real; 
begin 
read(n); 
for i:=1 to n do
read(a[i]); 
min:=a[1]; 
for i:=2 to n do 
if a[i]<min then 
min:=a[i]; 
max:=a[1]; 
for i:=2 to n do 
if a[i]>max then 
max:=a[i]; 
writeln('максимальный элемент равен ',max,''); 
writeln('минимальный элемент равен ',min,''); 
end.
8) Program n1; var a:array[1..100] of real; i,n:integer; min,max,nom1,nom2:real; begin read(n); for i:=1 to n do read(a[i]); min:=a[1]; nom1:=1; for i:=2 to n do if a[i]<min then begin min:=a[i]; nom1:=i; end; max:=a[1]; nom2:=1; for i:=2 to n do if a[i]>max then begin max:=a[i]; nom2:=i; end; writeln('максимальный элемент равен ',max,', его номер ',nom2,''); writeln('минимальный элемент равен ',min,', его номер ',nom1,''); end.
9) Program n1; var a:array[1..100] of real; i,n:integer; min,max,s,sr:real; begin read(n); randomize; for i:=1 to n do begin a[i]:=random(100)+1; write(a[i],'  '); end; writeln; s:=0; sr:=0; for i:=1 to n do s:=s+a[i]; sr:=s/n; writeln('ср. арифм. = ',sr,''); min:=a[1]; for i:=2 to n do if a[i]<min then min:=a[i]; max:=a[1]; for i:=2 to n do if a[i]>max then max:=a[i]; writeln('максимальный элемент равен ',max,''); writeln('минимальный элемент равен ',min,''); end.
Ионов202
//PascalABC.Net 3.2
{1}
begin
var a:=readArrinteger('Вводите: ', readinteger('n ='));
write ('Ср. арифметическое: ', a.Average);
end.

{2}
begin
var a:=readarrinteger('Водите: ', readinteger('n ='));
var sum:=0;
for var i:=0 to length(a)-1 do if i.isodd then sum+=a[i];
write ('Сумма: ', sum);
end.

{3}
begin
var a:=readarrinteger('Вводите: ', readinteger('Кол-во элементов: '));
var otr:=0; var pol:=0;
for var i:=0 to length(a)-1 do if a[i]<0 then otr+=1 else pol+=1;
write('Массив: '); a.Println;
if otr=pol then write ('Отрицательных и положительных элементов равное кол-во') else 
if otr>pol then write('Отрицательных больше на ', otr-pol) else
write ('Положительных больше на ', pol-otr);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)составьте программу, которая выводит на экран таблицу перевода а, а+1, а+ минут в секунды. границы а и б вводятся с клавиатуры. введите границы : 12 18 12 мин = 720 18 мин =1080 сек 2)составить программу для решения следующей : начав тренировки, спортсмен в первый день пробежал 10 км. каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. какой суммарный путь пробежит спортсмен за n дней? ( все в паскале)
Ваше имя (никнейм)*
Email*
Комментарий*