a580028r
?>

Впаскале: составьте программу котораяж из слова "компилятор" составляет слова: "мотор", "комок", "пилот"

Информатика

Ответы

arturo95

var a: string;

begin

readln(a);

writeln(a[3],a[2],a[8],a[2],a[length(a)]);

writeln(a[1],a[2],a[3],a[2],a[1]);

writeln(a[4],a[5],a[6],a[2],a[8]);

end.

palchiknr
Function arccos(x: real): real; var t: real; begin         t: =arctan(sqrt(1-x*x)/x);         if x< 0 then arccos: =t+pi         else arccos: =t end; var   a,b,c,p,p2,s,alpha,beta,gamma,h: real; begin   read(a,b,p);   c: =p-a-b;   p2: =p/2;   s: =sqrt(p2*(p2-a)*(p2-b)*(p2-c));   alpha: =arccos((b*b+c*c-a*a)/(2*b*c));   beta: =arccos((a*a+c*c-b*b)/(2*a*c));   h: =a*sin(beta);   alpha: =alpha*180/pi;   beta: =beta*180/pi;   gamma: =180-alpha-beta;   writeln('c=',c);   writeln('alpha=',alpha: 0: 2,', beta=',beta: 0: 2,', gamma=',gamma: 0: 2);   writeln('s=',s,', h=',h) end.
karpachevamarina
Код pascal: const     n = 3;     m = 4; var     a: array[1..n,1..m] of shortint;     b: array[1..n] of byte;     i,j,k: byte; begin randomize; for i: = 1 to n do       begin       k: =0;       for j: = 1 to m do               begin               a[i,j]: =random(21)-10;               write(a[i,j]: 3,' ');               if a[i,j] > 0 then k: =k+1;               end;       b[i]: =k;       writeln;       end; writeln; for i: = 1 to n do       write(b[i],' ') end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Впаскале: составьте программу котораяж из слова "компилятор" составляет слова: "мотор", "комок", "пилот"
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kulagin777
roma8
Sergei-Gradus199
ilukianienko458
apromovich1
Radikovnanikolaeva
svetarakityanskaya
vitbond12
fshevxuzheva313
master-lamaster
foto5113161
Vrezh
achernakov
Koshkina Alekseevna
abrolchik8511
▲