1 конечная последовательность шагов в решении , приводящая от исходных данных к
требуемому результату. 1 1 за правильное определение
алгоритма.
2 b, c 2 1 за каждый
правильный ответ
3
№ команда
⦁ c) выберите оператора
⦁ b) введите номер телефона
⦁ a) проверьте и подтвердите номер телефона
⦁ e) введите в окно «сумма оплаты»
⦁ d) внесите купюры в купюроприёмник (возможно ввод нескольких купюр)
⦁ h) нажать кнопку «оплатить»
⦁ g) дождитесь распечатки чека
⦁ f) перейдите в окно «главная»
3.1) 1. c), 2. b), 3. a), 4. e), 5. d), 6. h), 7. g), 8. f)
.
3.2) система команд исполнителя 2 2 за полностью
правильную
последовательность.
1 за 4 правильные
последовательности.
1 за правильный
ответ
1
4 словесная запись алгоритма 1 1 за правильный ответ
5 1 пп 6 и1 11 пл 2 1 за поворот на лево
1 за команду идти 2 шага
2 и4 7 пп 12 и2
3 пл 8 и1 13 пл
4 и1 9 пп 14 и2
5 пл 10 и1 15 с
6 6.1) разветвляющийся алгоритм 1 1 за правильный
тип алгоритма
6.2) алгоритм выполнение которого зависит от
проверки некоторых условий называется 2 1 за определение
разветвляющимся алгоритмом. разветвляющего
в данной программе проверяется правильный алгоритма и 1 за
ответ «гадкий утёнок», если ответ верный, то описание фрагмента
звучит соответствующая музыка и этот ответ кода программы
получает значение переменной 1, а иначе ответ неверный звучит другая музыка и значение переменной присваивается 2 (для подсчёта правильных ответов).
примечание: принимается ответ ученика, если он описывает как проходит проверка, без подсчёта переменной. ветвления.
7
4 1 за блок цикла
1 за блок присвоения
1 за команду
1 за команду
8 движение объекта. создание простой анимации в игровой среде. объект будет двигаться постоянно, дойдя до края оттолкнётся и
обратно будет двигаться. 1 1 за правильный ответ
9 2 1 за правильное определение координаты;
1 за правильное направление спрайта
10 команда 1 1 за правильное
определение команды
место
для отметки
итого 20
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу ! вот условие: разработать схему алгоритма, который вводит массив из n целых чисел и выводит на экран этот же массив в прямом и обратном порядке. протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. на паскале
a:array[1..1024] of integer;
begin
randomize;
write('N=');
readln(n);
for i:=1 to n do
a[i]:=random(2*n+1)-n;
write('V pramom poradke - ');
for i:=1 to n do
write(a[i],' ');
writeln;
write('V obratnom poradke - ');
for i:=n downto 1 do
write(a[i],' ');
writeln;
end.