gr1schinanata
?>

Задана последовательность из n целых чисел. определить среднее арифметическое отрицательных элементов последовательности. написать программу в pascal.

Информатика

Ответы

Vladimirovna-Ignatenko1890
Var
a: array[1..100] of integer;
i,n,c,h: integer;
  begin
    writeln('Введите кол-во элементов последовательности:');    readln(n);
    writeln('Введите последовательность:');
    for i:=1 to n do
      begin
       read(a[i]);
         if  a[i]<0 then
          begin
           c:=c+a[i];
           h:=h+1;
          end;
      end;
    writeln(c/h);
  end.
Vyacheslav_Nikolaevna

Хотя слово «центнер» немецкого происхождения и означает «сто мер», традиционно в Германии в старину за меру веса принимали не килограмм, а фунт, который соответствует приблизительно 500 граммам. То есть 100 фунтов — 50 килограммов. Этой мерой веса в старину пользовались люди, занятые в сельском хозяйстве: например, центнер картофеля — полный мешок, 50 кг. В разных частях Германии центнер был разный: в Баварии, например, — 56 кг; в Брауншвейге — 46,77 кг; в Саксонии — 51,4 кг. Сейчас в Германии берётся усреднённая величина 50 кг[1].

:)

всего доброго

aluka

pascal

Объяснение:

var

 i, j ,k: integer;

 l, lnew: string;

 a: array of integer;

begin

 Write('Введите число >> ');

 ReadLn(l);

 SetLength(a ,length(l));

 for i := 0 to length(l) - 1 do

   a[i] := strtoint(l[i + 1]);    

 for i := 0 to length(l) - 2 do

     for j := i + 1 to length(l) - 1 do

       if a[i] > a[j] then

       begin

         k := a[i];

         a[i] := a[j];

         a[j] := k;

       end;

 

  for i := 0 to length(l) - 1 do

   lnew := lnew + inttostr(a[i]);

 WriteLn('Новое число равно ', lnew);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задана последовательность из n целых чисел. определить среднее арифметическое отрицательных элементов последовательности. написать программу в pascal.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mihailpolehin8
kristal1
ooottdi
Powerbasses5521
nane2924329
serge-lysoff
Tochkamail370
Valerii276
Varagyan1728
Irina
stailwomen31
Svetlana1877
Акоповна
oslopovavera
stark11