?>
13. для какого значения числа z высказывание ((z > 2)ú(z > 4)) →(z > 3) будет ложным? 14. определите значение переменной c после выполнения следующего фрагмента программы, в котором a, b и c – переменные целочисленного типа: a : = 27; b : = 13; if b div 5 > 2 then c : = b mod 5 + a mod 3 else c : = (b + a) mod 6; 15. определите, что будет напечатано в результате работы следующего фрагмента программы? var n, s, d: integer; begin readln(d); n : = 3; s : = 57; for i: = 2 to 5 do begin s : = s + n; n : = n + 4 end; write(s) end.
Ответы
14 т.к b div 5= 2
c := (b + a) mod 6;
c:= 40 mod 6
c:= 4
15. Ничего не будет напечатано, т.к программа не будет работать:
Паскаль будет ругаться, что не объявлен идентификатор i.
Но если бы он был, то на экран бы выводилось число 93