svetegal
?>

Напишите и ее решение в паскале. массивы составить программу для решения следующей : дан массив целых чисел. выяснить какой элемент массива больше, k-й или p-й.

Информатика

Ответы

зырянов_Юрьевна378
Var a,b,c:integer;
n:array [1..10] of integer;
begin
writeln('введите номера элементов для сравнения');
readln(a,b);
randomize;{скажите что посмотрели эту функцию в интернете и она нужна для подготовки программы к применению функции рандом}
for c:=1 to 10 do begin
n[c]:=random(-20,20);{так мы в массив ставим случайное число в диапазоне от -20 до 20}
writeln(n[c]);
end;
if n[a]<n[b] then writeln('меньший элемент массива под номером ' ,a,' больший элемент массива под номером ' ,b)
else writeln('меньший элемент массива под номером ' ,b,' больший элемент массива под номером ' ,a);
end.
Ubuleeva826
While - цикл с условием
for - цикл с известным количеством шагов (итераций)

чтобы воспользоваться for нужно знать точно количество шагов (интераций)

например, заполняем массив arr из 10 единиц типа int
for(i = 0; i < 10; i++) arr[i] = 0; // точно знаем что 10 элементов и делаем 10 интераций

если же нам не известно количество интераций цикла, например организовать ввод переменной до тех пор, пока пользователь не введет 0
сколько будет интераций - неизвестно и зависит сугубо от пользователя

int num;
do
{
cin >> num // вводим цифру
}
while(num != 0); // повторяем ввод, пока цифра не равна 0

( do while - разновидность while, в которой условие проверяется не перед первой интерацией, а после нее )

примеры представлены на c++, но в принципе и так понятно
alena
While - цикл с условием
for - цикл с известным количеством шагов (итераций)

чтобы воспользоваться for нужно знать точно количество шагов (интераций)

например, заполняем массив arr из 10 единиц типа int
for(i = 0; i < 10; i++) arr[i] = 0; // точно знаем что 10 элементов и делаем 10 интераций

если же нам не известно количество интераций цикла, например организовать ввод переменной до тех пор, пока пользователь не введет 0
сколько будет интераций - неизвестно и зависит сугубо от пользователя

int num;
do
{
cin >> num // вводим цифру
}
while(num != 0); // повторяем ввод, пока цифра не равна 0

( do while - разновидность while, в которой условие проверяется не перед первой интерацией, а после нее )

примеры представлены на c++, но в принципе и так понятно

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите и ее решение в паскале. массивы составить программу для решения следующей : дан массив целых чисел. выяснить какой элемент массива больше, k-й или p-й.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Егорова
Liliya_Ivanova
si0000
argent
Chistov9721209
titancore
Artyukhin545
zotcet7
Anastasiya1537
ajuli2
Александр Джабраиловна1967
Памагите сор информатика сросно​
dianabuchkina
alfastore4
bd201188
MikhailNechaeva