zuelv
?>

Составить программу в паскале, в которой: а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345. б) подсчитать и вывести отрицательные элементы массива

Информатика

Ответы

Valentina1520

fpc ide 2.6.0 

var a,b: array[1..10] of integer; i,k,z: integer; begin z: =1; for i: =1 to 10 dobegina[i]: =random(25)-15; if a[i]> 0 then a[i]: =sqr(a[i]); if a[i]< 0 then begin b[z]: =a[i]; a[i]: =12345; inc(k); inc(z); end; end; for i: =1 to 10 dowriteln('a[',i,']=',a[i]); writeln('kol-vo otricatelnux: ',z-1); for i: =1 to z-1 do writeln('otricatelnie elementy: ',b[i]); readln; end.

borisovaks496
//pascal abc.net v3.1 сборка 1172 const   n=15;   m=10; var   ma: array[1..n,1..m] of integer;   i,j,sum,co: integer; begin   randomize;   writeln('matrix: ');   for i: =1 to n do     begin     for j: =1 to m do       begin       ma[i,j]: =random(10)-3;       write(ma[i,j]: 4);       end;     writeln;     end;   for j: =1 to m do   begin   for i: =1 to n do     if ma[i,j]> 0 then     begin       sum: =sum+ma[i,j];       inc(co);     end;   writeln('sum ',j,': ',sum);   writeln('count ',j,': ',co);   sum: =0;   co: =0;   end; end.
mausgaly

пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук пук

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу в паскале, в которой: а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345. б) подсчитать и вывести отрицательные элементы массива
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergei Gaishun
mar1030
Alena824
oksanashabanovadc3197
meteor90
arturcristian
romka1210
Морозов
Михайлович_гергиевич315
Nikolaevich_Vladimirovich1509
mvinogradov6
keykov35
Вадим
colus77
UvarovAndrei