Verakravez8790
?>

Выручайте, написать программу в паскале: " даны два целых числа: d (день) и m (месяц), определяющие правильную дату не високосного года. вывести значения d и m для даты, предшествующей указанной." используя команду case.

Информатика

Ответы

Павловна1750
Program a;
var D,M: integer;
begin 
readln (D,M); //DD MM
if (D<>1) then Writeln (D-1,' ',M) 
else
case M of
01 : Writeln('31 12');
02 : Writeln('31 01');
03 : Writeln('28 02');
04 : Writeln('31 03');
05 : Writeln('30 04');
06 : Writeln('31 05');
07 : Writeln('30 06');
08 : Writeln('31 07');
09 : Writeln('31 08');
10 : Writeln('30 09');
11 : Writeln('31 10');
12 : Writeln('30 11');
end;
end.
koldunovan

1. У задачах, які передбачають виконання альтернативних дій, використовують оператор повного розгалуження. Для запису оператора повного розгалуження додатково використовують службове слово

else:

if <логічний вираз>:

блок команд 1

else:

блок команд 2

2. Наведіть приклади, коли у програмі варто застосовувати оператор неповного розгалуження.

Складіть програму мовою Python, у якій із двох введених цілих чисел А і В (<100) виводиться найбільше з них.

3. Як мовою програмування Python реалізувати вкладені розгалуження?

Якщо є потреба врахувати значення декількох логічних виразів, то використовують вкладені розгалуження:

if <логічний вираз1>:

блок команд 1

elif <логічний вираз2>:

блок команд 2

...

elif <логічний вираз n>:

блок команд n

else:

<блок команд інакше>

voen-torg
Граф - множество вершин и ребер, соединяющих эти вершины.
Он несет информацию об элементах системы и связи между ними.
Элементы системы изображаются как вершины или узлы графа.
Отношения между ними изображаются как ребра или дуги графа.
Деревом называют ациклический (то есть между любыми вершинами есть только один путь), связный (то есть от любой вершины графа можно добраться в другую) граф.
Корень дерева - это вершина с нулевой степенью захода (то есть в нее не ведут другие ребра). Для неориентированного графа это просто выбранная нами вершина.
Ветви - это ребра дерева.
Листья дерева - это вершины с нулевой степенью исхода (то есть из них не выходят ребра), т.е. не имеющих поддеревьев.
Надеюсь объяснил доступно.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Выручайте, написать программу в паскале: " даны два целых числа: d (день) и m (месяц), определяющие правильную дату не високосного года. вывести значения d и m для даты, предшествующей указанной." используя команду case.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

atupicyn754
ev89036973460
Alekseeva_Khlistov
Bella Sergei
akbmaslafarkop3175
mikhisakov2017
Maksim Dmitrii1579
Анатолий
ВладимировнаАлександр1421
ktv665
kruttorg
minaskorolev8
Присакарь520
olgalooo
Игорь Андрей