fymukham
?>

Нужно написать программу, которая: удваивает меньшее из двух чисел и обязательно сообщает, какие два числа были введены и какое число наименьшее

Информатика

Ответы

aa276568
Program programma;
var a,b,c: integer;
begin
writeln ('Введите два числа');
read (a,b);
if a>b then  writeln ('Были введены числа ',a,' и ',b,'. Наименьшее число ',b,'. Удвоенное наименьшее число ',2*b); 
if b>a then  writeln ('Были введены числа ',a,' и ',b,'. Наименьшее число ',a,'. Удвоенное наименьшее число ',2*a); 
end.
Olga-Lev1160

К электронным носителям относят носители для однократной или многократной записи (обычно цифровой) электрическим :

оптические (CD-ROM, DVD-ROM, Blu-ray Disc);

полупроводниковые (флеш-память, SSD-диски);

магнитные (магнитные ленты, дискеты, жёсткие диски).

Электронные носители имеют значительные преимущества перед бумажными (листами, газетами, журналами):

по объёму (размеру) хранимой информации;

по удельной стоимости хранения;

по экономичности и оперативности предоставления актуальной (предназначенной для недолговременного хранения) информации;

по возможности предоставления информации в виде, удобном потребителю (форматирование, сортировка).

Недостатки:

низкое разрешение экрана, в некоторых случаях;

хрупкость устройств считывания;

вес (масса), в некоторых случаях;

зависимость от источников электропитания;

необходимость наличия устройства считывания/записи для каждого типа и формата носителя.

Может в неожиданный момент сломаться

В настоящее время электронные носители вытесняют бумажные во всех отраслях жизни, что приводит к сбережению древесины.

ekvld708

Работа станков с ЧПУ (числовым программным управлением) осуществляется с систем числового программного управления – совокупности функционально взаимосвязанных и взаимодействующих технических и программных средств. Конструктивно системы ЧПУ различают разомкнутые, замкнутые и самонастраивающиеся. Разомкнутые системы ЧПУ используют один поток информации. Устройство считывает программу, после чего подает команды механизму, осуществляющему перемещение исполнительных элементов станка. СЧПУ замкнутого типа использует два потока информации. Один поток поступает от считывающего устройства, другой от устройства, измеряющего перемещения исполнительных элементов станка. Устройства самонастраивающихся СЧПУ имеют возможность корректировать информацию в зависимости от изменений, происходящих при обработке предыдущей заготовки. Самонастраивающиеся системы позволяют повысить точность обработки, так как изменения запоминаются в устройствах самонастройки памяти станка, после чего преобразуются в управляющий сигнал. Автоматическая при процесса обработки заготовки к изменяющимся условиям – важное свойство самонастраивающихся СЧПУ. Существует классификация систем числового программного управления по виду управления движением. СЧПУ бывают позиционными, прямоугольными и контурными. Позиционные системы – это системы, обеспечивающие точную установку исполнительного механизма в заданное положение. До начала процесса обработки выполняется установка исполнительного элемента в точке с заданными координатами, после этого начинается обработка. В отличие от позиционных систем прямоугольные системы обеспечивают последовательное включение продольной и поперечной подач станка при обработке поверхности ступенчатой формы. Данный вид СЧПУ используется в токарных, револьверных, фрезерных станках. Системы ЧПУ, обеспечивающие непрерывное управление рабочими элементами для получения необходимого контура обработки, называют контурными.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу, которая: удваивает меньшее из двух чисел и обязательно сообщает, какие два числа были введены и какое число наименьшее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

argent
AndreiFaikov1943
baxirchik
klkkan
ba5-m
vypolga1347
matveevaev81
kamimoza
ksenyabobrovich7214
Гарик383
Ольга1915
Морозов
Глазкова633
Ivanovich-A.V
banketvoshod