Аношкина1696
?>

Написать программу , которая увеличивает число на 7, если оно меньше нуля и уменьшает на 2. если исходное число больше 0

Информатика

Ответы

Евгений
Var a,b,c:integer;
begin
writeln('введите число');
readln(a);
if a<0 then b:=a+7 else b:=a-2;
if a=0 then while a=0 do begin writeln('введите другое число'); end;
writeln('полученное число ', b);
end.
Любовь-Волков1205
var x : real;
begin 
 writeln ( 'Введите число : '); 
 readln (x); 
  if (x<0) then x:=x+7  
  else if (x>0) then x:=x-2; 
 writeln (' Конечное число : ',x);
end.
Ofelya1308

Правила оформления таблиц:

1.  Единая последовательная нумерация таблиц.

2. Заголовок таблицы должен давать представление о содержащейся в ней информации.

3.  Заголовки столбцов и строк должны быть краткими, не содержать лишних слов и, по возможности, сокращений.

4.  В таблице должны быть указаны единицы измерения. Если они общие для всей таблицы, то указываются в заголовке таблицы (либо в скобках, либо через запятую после названия). Если единицы измерения различаются, то они указываются в заголовке соответствующей строки или столбца.

5.  Желательно, чтобы все ячейки таблицы были заполнены.

Объяснение:

ruslanchikagadzhanov

Объяснение:

В конце XIX века Герман Холлерит в Америке изобрел счетно-перфорационные машины. В них, так же как и в Аналитической машине Бэббиджа, использовались перфокарты, но только не для представления программы, а для хранения числовой информации. Каждая такая машина могла выполнять только одну определенную программу, манипулируя с перфокартами и числами, пробитыми на них. Счетно-перфорационные машины осуществляли перфорацию, сортировку, суммирование, вывод на печать числовых таблиц. На этих машинах удавалось решать многие типовые задачи статистической обработки, бухгалтерского учета и другие.

Г. Холлерит основал фирму по выпуску счетно-перфорационных машин, которая затем была преобразована в фирму IВМ — ныне самого известного в мире производителя компьютеров.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу , которая увеличивает число на 7, если оно меньше нуля и уменьшает на 2. если исходное число больше 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Мирзоев Денис
qwe54344
ekaterinaorl1998
Zeitlinama7067
h777eta
Хрулёва
Avetisyan575
aamer9992680
Chernaya
Mariya Filippov
Zuriko1421
Владимирович_Слабый
ren7869
serov555zaq5
Ivanovna