Составить программу вычисления суммы мест, на которых в строке, введенной с клавиатуры, стоят согласные буквы. например в 'строке' сумма мест согласных букв равняется 1+2+3+5+=11
Var s,g:string; sum:integer; begin g:=''; read(s); sum:=0; for var i:=1 to length(s) do if (pos(s[i],g)>0) then sum:= sum+i; writeln(sum); end. //ABC Pascal
Александра Викторович531
03.06.2022
Правила задания имени файла определяются операционной системой и используемой файловой системой. Вообще файловая система определяет общую структуру именования, хранения и организации файлов в операционной системе. Файловая система FAT (File Allocation Table) поддерживается операционнымисистемами DOS и Windows (в DOS — FAT16; в Windows9x — FAT16 и FAT32). Это файловая система, основанная на таблице размещения файлов, которая поддерживается операционной системой для отслеживания состояния различных сегментов дискового пространства, используемого для хранения файлов. NTFS (Windows NT File System) — файловая система операционных систем Windows NT и Windows 2000. Улучшенная по сравнению с FAT файловая система, разработанная для использования специально с ОС Windows NT. Она выполняет те же функции, что и FAT, но, кроме того, поддерживает средства восстановления файловой системы и допускает использование чрезвычайно больших носителей данных. Также поддерживает объектно-ориентированные приложения, обрабатывая все файлы как объекты с определяемыми пользователем и системой атрибутами. Каждый файл на томе NTFS представлен записью в специальном файле, называемом “главной файловой таблицей” (MFA). В операционных системах семейства DOS имя файла может содержать от 1 до 8 символов, можно использовать символы латинского алфавита, арабские цифры и некоторые другие символы; есть ряд символов, использование которых в имени запрещено. В операционных системах семейства Windows имя может содержать уже от 1 до 255 символов, причем набор символов, из которых можно составлять имена файлов, расширяется. В частности, можно использовать буквы национальных алфавитов, пробелы и т. д. Windows, как правопреемница DOS, обеспечивает совместимость собственных “длинных” имен с короткими именами DOS, т. е. у файла Windows есть дополнительный атрибут — имя этого файла в DOS. Строчные и прописные буквы в именах файлов не различаются. По-другому дело обстоит в операционных системах семейства Unix. Там строчная и прописная буквы различаются, поэтому имена, записанные одними и теми же буквами, но имеющие различия в регистрах, будут разными. Расширение имени файла записывается после точки и может содержать от 1 до 3 символов в DOS и больше 3 — в Windows. Чаще всего в расширение вкладывается определенный смысл (хотя пользователь может задавать и бессмысленные расширения) — оно указывает на содержимое файла или на то, какой программой был создан данный файл. Например, DOC, TXT — расширения текстовых файлов, COM, EXE — исполнимых файлов, INI — инициализационных файлов, PAS, BAS, CPP — исходные тексты программ на соответствующем языке программирования, и т. д. В операционной системе Windows именно по расширению файлы ассоциируются с определенной программой, с которой они могут быть открыты для просмотра или модификации. .
Koshovkina1721
03.06.2022
Год создания первого компьютера - 1938 год, машина Z1, инженер Конрад Цузе. Первым функционирующим программируемым компьютером принято считать Z3(1941 год) этого же инженера.
Год создания первого отечественного компьютера- 1951 год, МЭСМ, разработана группой Лебедева в Киеве.
Год открытия радиосвязи- 1995 год, изобретатель А. С. Попов
Год первого полета человека в космос- 1961 год, Ю. Гагарин
Год принятия христианства на Руси- 988 год.
Год первого упоминания в летописи о Москве- 1147 год, летопись "Москва"
Год начала великой отечественной войны- 1941 год,
Год запуска первого искусственного спутника земли- 1957 год, «Спутник-1», СССР
s,g:string;
sum:integer;
begin
g:='';
read(s);
sum:=0;
for var i:=1 to length(s) do
if (pos(s[i],g)>0) then sum:= sum+i;
writeln(sum);
end.
//ABC Pascal