neblondinka19
?>

Напишите программу находящую среднее арифметическое четных чисел, вводимых с клавиатуры. решить с цикла с параметром

Информатика

Ответы

steam22-9940
Program prl;
uses crt;
var i,n,summa:integer;
      srednee:real;
      a:arra[1..100] of integer;
begin
write('Введите кол-во четных элементов');
readln(n);
summa:=0;
for i:=1 to n do begin
write('Введите ',i,' элемент:'); 
readln(A[i]);
summa:=summa+A[i];
end;
srednee:=summa/(n div 2);
writeln('Среднее арифметическое',srednee:3:2);//
readln;
end.
shkola8gbr
Для записи максимального числа необходимо  в наибольшем разряде числа записать самую большую цифру,то есть 9,поскольку это палиндром,то и последняя цифра будет 9.
9+9=18,39-18=21-сумма оставшихся  пяти  цифр.(Если использовать в числе две цифры 7, то сумма оставшихся трех цифр составит 7,а из этих трех цифр две 4 не получится ,а одна не удовлетворяет условие,поскольку на две цифры останется сумма 3.)В этом числе может быть только одна 7,и число выглядит так 9**7**9,а сумма неизвестных четырех цифр-14.
среди этих четырех цифр две 4,тогда сумма двух оставшихся цифр-6,то есть это две 3.Осталось только записать это максимальное число. 9437349.Проверим 9+4+3+7+3+4+9=39
obitelsvel8
Три символа алфавита могут быть закодированы в системе счисления по основанию 3, т.е. в троичной системе счисления.
При этом под первым номером кодируется число 0, которое записано по условию как , т.е. символ F кодируется нулем.
Вторым номером кодируется число 1 и его запись по условию N, откуда мы узнаем, что символ N кодируется цифрой 1. Тогда оставшийся символ S кодируется цифрой 2. И действительно, третьей идет комбинация символов S.
Любой член в последовательности кодов может быть получен путем перевода в троичную систему числа, на единицу меньшего номеру этого члена (поскольку отсчет кодов идет с нуля, а члены последовательности нумеруются с единицы). Проверим наше построение для контрольного значения n99=NFNSS.
98(3)=10122 -> NFNSS, что соответствует условию.
Теперь само решение.
7) 6(3)=00020 -> FFFSF
27) 26(3)=00222 -> FFSSS
90) 89(3)=10022 -> NFFSS
101) 100(3)=10201 -> NFSFN
196) 195(3)=21020 -> SNFSF

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу находящую среднее арифметическое четных чисел, вводимых с клавиатуры. решить с цикла с параметром
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

osherbinin
Хачатурович978
phiskill559
Матвеев
lika080489
alexandrxzx09
panasenko68
buleckovd8724
agaltsova86
Andreevich440
dobrovolsky-tmz1
gudachaa1480
vasenkova1981
Peshkov
lebedev815