nekarpova
?>

даны два числа. если квадратный корень из второго числа меньше первого числа, тоувеличить второе число в пять раз.написать программу в delphi​

Информатика

Ответы

Plyushchik_Nikita
//PascalABC.NET Версия 3.0 Сборка 1150
var n:integer;
begin
  writeln('Сколько стоит товар?');
  readln(n);
  n:=1000-n;
  writeln('Сдача ',n,' рублей. Нужны купюры:');
  writeln(n div 500, ' по 500 рублей, ', (n-(n div 500)*500)div 100, ' по 100 рублей, ', (n mod 100) div 50, ' по 50 рублей, ', (n-(n div 50)*50) div 10,' по 10 рублей, и ещё ', n mod 10, ' рублей мелочью.');
end.

Результат работы:
Сколько стоит товар?
324
Сдача 676 рублей.
Нужны купюры:
1 по 500 рублей, 1 по 100 рублей, 1 по 50 рублей, 2 по 10 рублей, и ещё 6 рублей мелочью.
манукян29

ответ:это метасимволы

Объяснение:

Для каждого понятия языка должна существовать единственная мета-

формула, в левой части которой указывается определяемое понятие, т.е.

метапеременная языка БНФ, а правая часть формулы тем или иным

бом задает все множество значений этой метапеременной, т.е. все допусти-

мые конструкции, которые объединяются в это понятие. Для большей

наглядности все понятия (метапеременные) обычно заключаются в спе-

циальные угловые скобки " < " и " > " (предполагается, что эти скобки не

принадлежат алфавиту определяемого языка, т.е. являются метасимвола-

ми), например (число), <арифметическое выражение) и т.д.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

даны два числа. если квадратный корень из второго числа меньше первого числа, тоувеличить второе число в пять раз.написать программу в delphi​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mursvita943
Ruslanovich1217
Karina-evgenevna1899
Aleksandrovna-Marina
demakova1969
mihalewanadia20176987
uzunanna19922488
Валиахметова
artemy682719
Petrakova Ilyushin
victoria-112296363
hello
ilma20168
targovich
versalmoda2971