Екатерина_Кирушев
?>

С++ 1. напишите программу, при которой можно определить стоимость аренды автомобиля. исходные данные для расчета- время аренды(цело количество часов) и тип автомобиля(такси, микроавтобус, автобус) 2. напишите программу, в окне которой в виде круговой диаграммы отображается информация о расходах среднестатистической семьи на питание, транспорт, одежду, образование.

Информатика

Ответы

kmb1960679
Если в первой задаче тип --- цна аренды за час, то вот ваша первая задача:
#include <cstdio>
#include <iostream>
using namespace std;
int main()
{
int tip, kolvo;//tip - тип автомобиля, kolvo -количество часов
scanf("%d %d", &kolvo, &tip);
printf("%d", kolvo*tip);
return 0;
}
Simbireva
Тут есть два варианте решения, у Вас в задании написано что число Х и число А уже даны, то бишь с клавиатуры вводить их не надо. Тогда 1 вариант решения 1. и 2. задания:
1)
var x: integer;
begin
x:=5; // Поменяйте значение на нужное
writeln ('Квадрат числа ', x, ' = ',sqr(x));
end.
2)
var a,b: integer;
begin
a:=3; // Поменяйте значение на нужное
b:=a*2;
writeln ('Сумма A и B = ', a+b);
end.
2 вариант решения, все значения вводятся с клавиатуры:
1)
var x: integer;
begin
write ('Введите число Х: '); read(x);
writeln ('Квадрат числа ', x, ' = ',sqr(x));
end.
2)
var a,b: integer;
begin
write ('Введите число А: '); read (a);
b:=a*2;
writeln ('Сумма A и B = ', a+b);
end.
irinatikhonov
Program gulkakh;
const n=5;
var a:array[1..n,1..n] of integer;   
i,j,k,max,stroka:integer;
begin
writeln('Исходная матрица:');
for i:=1 to n do   
for j:=1 to n do    begin   
 a[i,j]:=random(20)-10;   
 write(a[i,j],' ');   
  if j=n then writeln; 
  end;   

 stroka:=1;
max:=a[1,1];

for i:=1 to n do
for j:=1 to n do begin
if max<a[i,j] then begin
max:=a[i,j];
stroka:=i;
end;
end;

k:=n;

for i:=stroka to n-1 do
for j:=1 to n do
a[i,j]:=a[i+1,j];
k:=k-1;
writeln('Без удаленной строки:');
for i:=1 to k do 
 for j:=1 to n do begin
  write(a[i,j],' '); 
if j=n then writeln; 
end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С++ 1. напишите программу, при которой можно определить стоимость аренды автомобиля. исходные данные для расчета- время аренды(цело количество часов) и тип автомобиля(такси, микроавтобус, автобус) 2. напишите программу, в окне которой в виде круговой диаграммы отображается информация о расходах среднестатистической семьи на питание, транспорт, одежду, образование.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ASRodichev
Nataliatkachenko1
Галина-Юлия1292
maksim1lssah575
Natysya7777
Karmelita1978
Александровна
Роман_Гречина
Leobed917670
mzubenko6
delonghisochi
info122
stendpost
Arsen-araqelyan20164
mantseva
▲