Примерно так. На псевдоязыке, который легко переводится в тот, который знаком
//
Сумм=0;
Конец=0;
Ввод(Ч);
Пока (Ч#Конец) Цикл
Если Проверить(Ч)=1 Тогда
Сумм=Сумм+Ч;
КонецЕсли;
Ввод(Ч);
КонецЦикла;
Печать(Сумм);
//
//
Функция Проверить(П)
Если Остаток(П,10)=4 Тогда
Если Остаток(П,6)=0 Тогда
Возврат(1);
КонецЕсли;
КонецЕсли;
Возврат(0);
КонецФункции
//
Этот текст не использует массивы, поэтому количество вводимых чисел неограничено. Их величина определяется описанием переменной(если в языке оно явно требуется, для приведенных данных достаточно описать как ЦЕЛОЕ(INTEGER)). Сумм описать побольше(если требуется).
Если в языке нет функции Остаток(обычно MOD), напиши свою, это очень просто.
Повторюсь, в Паскаль, Бейсик, 1С текст переводится очень легко, в С(Java, PHP и пр.) чуть сложнее, там немного другой синтаксис, но это преодолимые проблемы.
Паша имеет выйгрушную стратегию и сможет выйграть за один ход, если s=27 тогда ему достаточно добавить один камень чтобы игра закончилась при 28 камнях в куче или если s=14,15,16,17,18,19,20,21,22(44/2 и 28/2 т.е от 14 до 22), тогда не обходимо удвоить количество камней в куче.
Объяснение:
Паша имеет выйгрушную стратегию и сможет выйграть за один ход, если s=27 тогда ему достаточно добавить один камень чтобы игра закончилась при 28 камнях в куче или если s=14,15,16,17,18,19,20,21,22(44/2 и 28/2 т.е от 14 до 22), тогда не обходимо удвоить количество камней в куче.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая вводит натуральное число n и определяет его факториал, то есть произведение натуральных чисел от 1 до n : n ! = 1·2·{}· n . входные данные входная строка содержит одно натуральное число n . выходные данные программа должна вывести одно число – факториал введённого числа n .
var i,x,a:longint;
begin
readln(a);
x:=1;
for i:=2 to a do
x:=x*i;
writeln(x);
end.