АннаМаргарита
?>

Синформатикой. паскаль 1. вычислить и напечатать значения функции y=6*x2-9*x для x от 1 до 10 с шагом в 1. 2. написать программу, которая выводит целые числа в промежутке от 1 до 50, кратные двенадцати и считает их количество, сумму и произведение.

Информатика

Ответы

alekseymedvedev1981

переберём все числа в диапазоне [10; 100). сохраним наше текущее число в отдельную переменную. пока копия числа больше нуля, будем умножать переменную произведения этого числа на последнюю цифру числа (% 10). потом удалять последнюю цифру у копии числа (// 10).

код

for i in range(10, 100):

    i1 = i

    pr = 1

    while i1 > 0:

        pr = pr * (i1 % 10)

        i1 = i1 // 10

    if i == pr*2:

        print(i)

juliat200520

будем поддерживать переменную cur и хранить в ней текущее число для вывода. также будем поддерживать переменую k и хранить количество уже выведенных чисел cur. в цикле будем выводить cur и увеличивать k на 1. если k стало равно cur, увеличим cur на 1 и сбросим k на 0. и, очевидно, будем делать это n раз.

код

n = int(

cur = 1

k = 0

for i in range(n):

    print(cur, end=' ', flush=true)

    k = k + 1

    if k == cur:

        k = 0

        cur = cur + 1

print()

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Синформатикой. паскаль 1. вычислить и напечатать значения функции y=6*x2-9*x для x от 1 до 10 с шагом в 1. 2. написать программу, которая выводит целые числа в промежутке от 1 до 50, кратные двенадцати и считает их количество, сумму и произведение.
Ваше имя (никнейм)*
Email*
Комментарий*