Напишите программу. дан массив из 10 числовых элементов. у 5го элемента индекс должен быть равен 173. вывести сумму всех ключей и сумму значений элементов.
В двоичной системе: 1243(10)=2^10+2^7+2^6+2^4+2^3+2^1+1 = 1024+128+64+16+8+2+1 = 1243(10) =10011011011(2) В восьмиричной системе: разбиваете двоичное представление на группы по 3 бита справа налево 011 = 3 011 = 3 011 = 3 10 = 2 Тогда в восьмиричной системе: 2333(8) = 2*8^3+3*8^2+3*8^1+3 = 1024+192+24+3=1243(10) В шестнадцатиричной системе: разбиваете двоичное представление на группы по 4 бита справа налево 1011 = B = 11(10) 1101 = D(16) = 13(10) 100 = 4 Тогда в шестнадцатиричной системе 4DB(16) = 4*16^2+13*16^1+11 =1024+208+11=1243(10)
marinamarinazmeeva2444
25.05.2022
// PascalABC.Net 3.0, сборка 1088 const n=30; var a:array[1..n] of integer; i,k:integer; begin Randomize; Writeln('*** Исходный массив ***'); k:=0; for i:=1 to n do begin a[i]:=Random(1001); Write(a[i],' '); if (a[i] mod 3 = 0) and (a[i] mod 10 = 1) then Inc(k) end; Writeln; Writeln('Количество найденных элементов равно ',k) end.
Напишите программу. дан массив из 10 числовых элементов. у 5го элемента индекс должен быть равен 173. вывести сумму всех ключей и сумму значений элементов.
В восьмиричной системе: разбиваете двоичное представление на группы по 3 бита справа налево
011 = 3
011 = 3
011 = 3
10 = 2
Тогда в восьмиричной системе: 2333(8) = 2*8^3+3*8^2+3*8^1+3 = 1024+192+24+3=1243(10)
В шестнадцатиричной системе: разбиваете двоичное представление на группы по 4 бита справа налево
1011 = B = 11(10)
1101 = D(16) = 13(10)
100 = 4
Тогда в шестнадцатиричной системе
4DB(16) = 4*16^2+13*16^1+11 =1024+208+11=1243(10)