Два игрока a и b бросают кубик и суммируют результаты бросков. победителем объявляется игрок, набравший первым объявленную сумму очков s. напишите программу, определяющую победителя
Var A,B:byte; S,Sa,Sb:integer; Begin WriteLn('S = ');ReadLn(S); Repeat Write('A = ');ReadLn(A); Sa:=Sa+A; Write('B = ');ReadLn(B); Sb:=Sb+B; Until (Sa>=S)or(Sb>=S); if (A>B) then WriteLn('Победил игрок A') else WriteLn('Победил игрок B') End.
muzaffarovich-Sergei1777
07.03.2023
Код Pascal:
Const N = 4; Var A:array[1..N,1..N] of integer; i,j:integer; S:real; Begin Randomize; WriteLn('Исходный массив:'); For i:= 1 to N do Begin For j:= 1to N do Begin A[i,j]:=random(21)-10; Write(A[i,j]:3,' ') End; WriteLn End; S:=0; For i:= 1 to N do S:=S+A[i,i]+A[N-i+1,i]; WriteLn('Сумма диагональных элементов: ',S) End.
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017 // Внимание! Если программа не работает, обновите версию!
procedure MaxR(a:array[,] of integer; var b:array of integer); begin b:=a.Rows.Select(r->r.Select(x->x).Max).ToArray end;
begin Writeln('*** Исходный массив ***'); var a:=MatrRandom(4,3,-99,99); a.Println(4); Writeln(4*a.ColCount*'-'); var b:array of integer; MaxR(a,b); Write('Максимумы построчно: '); b.Println end.
S,Sa,Sb:integer;
Begin
WriteLn('S = ');ReadLn(S);
Repeat
Write('A = ');ReadLn(A);
Sa:=Sa+A;
Write('B = ');ReadLn(B);
Sb:=Sb+B;
Until (Sa>=S)or(Sb>=S);
if (A>B) then WriteLn('Победил игрок A')
else WriteLn('Победил игрок B')
End.