D.Yu. Polina1703
?>

Народ! нужна ! кто силен в паскале, решить! 1) найдите длину окружности l и площадь круга s заданного радиуса r: l=2 πr (два пи ер), s= 2 π r в квадрате в качестве значения π использовать константу 2) написать программу вычисления стоимости некоторого количества (по весу) яблок. вес и цена за один килограмм вводится с клавиатуры. ниже представлен рекомендуемый вид экрана во время работы программы. введите исходные данные: цена одного килограмма яблок (руб) - 8, 5 вес яблок (кг) -2.3 стоимость покупки: 19, 55 руб

Информатика

Ответы

steff77
1
program krug;
var S,L,R:real;
const pi=3.14;
begin
writeln('введите радиус окружности');
readln(R);
L:=2*pi*R;
S:=pi*sqr(R);
writeln('S=',S,' L=',L);
end.

2
program appls;
var M,P,C:real;
begin
writeln('введите вес яблок');
readln(M);
writeln('введите цену за 1 килограмм');
readln(P);
C:=P*M;
writeln('общая стоимость яблок составляет ',C,' рублей');
end.
P.S. если ты будешь запускать программу в командной строке, то введи перед оператором "end" этот оператор:
readln();
P.S.S площадь окружности S=\piR в квадрате
Daletskaya982
//Dev-C++ 4.9.9.2

//а
#include <iostream>
using namespace std;

const int n=10;

int main(){
         int ar[n];
         int arsub[n];
         int m=0;
         cout<<"Enter m:";
         cin>>m;
         cout<<"Enter array:"<<endl;
         for(int i=0;i<n;i++)
          cin>>ar[i];
         for(int i=0;i<m;i++)
          arsub[i]=ar[i];
         for(int i=0;i<n-m;i++)
          ar[i]=ar[i+m];
         for(int i=0;i<m;i++)
          ar[i+(n-m)]=arsub[i];
         cout<<"Final array"<<endl;
         for(int i=0;i<n;i++)
          cout<<ar[i]<<' ';
        cin.get();
        cin.get();
 return 0;
}

//б
#include <iostream>
using namespace std;

const int n=10;

int main(){
         int ar[n];
         int arsub[n];
         int k,k1=0;
         cout<<"Enter k:";
         cin>>k;
         cout<<"Enter array:"<<endl;
         for(int i=0;i<n;i++)
          cin>>ar[i];
         for(int i=n-k;i<n;i++){
          arsub[k1]=ar[i];k1++;}
         for(int i=n;i>=k;i--)
          ar[i]=ar[i-k];
         for(int i=0;i<k;i++)
          ar[i]=arsub[i];
         cout<<"Final array"<<endl;
         for(int i=0;i<n;i++)
          cout<<ar[i]<<' ';
        cin.get();
        cin.get();
 return 0;
}
sryzhova6392

import java.util.Scanner;

class Main {

   public static void main(String [ ] args) {

       // Инициализация нужных переменных

       Scanner sn = new Scanner(System.in);

       double n = sn.nextInt();

       boolean ts = false;

       // До тех пор, пока n > 1 и n != 2, будет находится его корень. Если в один момент корень будет = 2, то выведется "YES"

       while(n > 1) {

           n = Math.sqrt(n);

           if(n == 2) {

               ts = true;

               break;

           }

       }

       if(ts) {

           System.out.print("YES");

       }

       else {

           System.out.print("NO");

       }

   }

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Народ! нужна ! кто силен в паскале, решить! 1) найдите длину окружности l и площадь круга s заданного радиуса r: l=2 πr (два пи ер), s= 2 π r в квадрате в качестве значения π использовать константу 2) написать программу вычисления стоимости некоторого количества (по весу) яблок. вес и цена за один килограмм вводится с клавиатуры. ниже представлен рекомендуемый вид экрана во время работы программы. введите исходные данные: цена одного килограмма яблок (руб) - 8, 5 вес яблок (кг) -2.3 стоимость покупки: 19, 55 руб
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alekseev13602
shoora
Екатерина15
mir5552
Константин Андрей
Daniil1945
prokodasha
grishin
sveta300856729
sinicin80
Яковчук1911
anusha33325
aromastil88
Kubataeva Nikolaevich1389
ЕленаГерасимова