манукян29
?>

Составить программу ( паскаль) для 5 целых чисел, найти максимальное из них p.s только с if then else (должно быть коротко

Информатика

Ответы

Anatolevich-sergeevna
Var
n1,n2,n3,n4,n5:integer;
begin
Readln(n1,n2,n3,n4,n5);
If (n1>n2) and (n1>n3) and (n1>n4) and (n1>n5) then
writeln('Максимальное число: ',n1)
else If (n2>n1) and (n2>n3) and (n2>n4) and (n2>n5) then
writeln('Максимальное число: ',n2)
else If (n3>n1) and (n3>n2) and (n3>n4) and (n3>n5) then
writeln('Максимальное число: ',n3)
else If (n4>n1) and (n4>n3) and (n4>n2) and (n4>n5) then
writeln('Максимальное число: ',n4)
else
writeln('Максимальное число: ',n5);
end.
nikolai37

ответ:

подписывайся на меня

какую роль играет для меня информатика, информатика дает нам много информации что изучает что то новое каждый день много програм и приложений, роботов коды для роботов мы люди это эпоха гаджетов что праграмиравоны за счет информации, люди дает мнения а другие используя коменты новое информатика для нас как открытое знание. много в мире професий связанные с информатика если знать от а до я то тогда можно взламывать , создавать, пиидумавать, рисовать и т. д информатика это крутяк.

Петренко1852
1)
var a:string;
    i, o: Integer;
    p: Real;
begin
     readln(o);
     a := inttostr(o);
     for i := 1 to length(a) do
        p := p + strtoint(a[i]);
     if (sqr(o) = p*p*p) then writeln('true')
        else writeln('false');
end.

2)
var a:string;
    i, o, p: Integer;
begin
     readln(o);
     a := inttostr(o);
     for i := 1 to length(a) do
        p := p + strtoint(a[i]);
     if (p mod 3 = 0) then writeln('true')
        else writeln('false');
end.

3)
var a, b, c: real;
begin
     readln(a, b, c);
     if ((a = b) and (b = c)) then writeln('true')
        else writeln('false');
end.

Всё проверено, удачи:)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу ( паскаль) для 5 целых чисел, найти максимальное из них p.s только с if then else (должно быть коротко
Ваше имя (никнейм)*
Email*
Комментарий*