Alyona
?>

Дано n-число дней с начала месяца. написать программу подсчета количества часов (has), минут(min) и секунд(sec) от начала месяца. входные данные n=5 выходные данные 120 7200 432000

Информатика

Ответы

Allahverdi_Мария475
Program n_1;
var has,min,sec,days:integer;
begin
days:=5;
Println('Число дней с начала месяца: ',days);
has:=days*24;
min:=has*60;
sec:=min*60;
Println('С начала месяца Дней, '+has+' Часов '+min+' Минут '+sec+' Секунд');
  end.
goodsled

Сортировка массива — это процесс распределения всех элементов массива в определённом порядке. Очень часто это бывает полезным. Например, в вашем почтовом ящике электронные письма отображаются в зависимости от времени получения; новые письма считаются более релевантными, чем те, которые вы получили полчаса, час, два или день назад; когда вы переходите в свой список контактов, имена обычно находятся в алфавитном порядке, потому что так легче что-то найти. Все эти случаи включают в себя сортировку данных перед их фактическим выводом.

Оглавление:

Как работает сортировка?

Сортировка массивов методом выбора

Сортировка массивов методом выбора в C++

std::sort()

Тест

Как работает сортировка?

Сортировка данных может сделать поиск внутри массива более эффективным не только для людей, но и для компьютеров. Например, рассмотрим случай, когда нам нужно узнать, отображается ли определённое имя в списке имён. Чтобы это узнать, нужно проверить каждый элемент массива на соответствие с нашим значением. Поиск в массиве с множеством элементов может оказаться слишком неэффективным (затратным).

Однако, предположим, что наш массив с именами отсортирован в алфавитном порядке. Тогда наш поиск начинается с первой буквы нашего значения и заканчивается буквой, которая идёт следующей по алфавиту. В таком случае, если мы дошли до этой буквы и не нашли имя, то точно знаем, что оно не находится в остальной части массива, так как в алфавитном порядке нашу букву мы уже Не секрет, что есть алгоритмы поиска внутри отсортированных массивов и получше. Используя алгоритм, мы можем искать определённый элемент в отсортированном массиве, содержащем 1 000 000 элементов, используя всего лишь 20 сравнений! Недостатком, конечно же, является то, что сортировка массива с таким огромным количеством элементов — дело сравнительно затратное, и оно точно не выполняется ради одного поискового за

Владислава531

Объяснение:

Var a,b:array [1..100,1..100] of real;

   current_row,current_column,rows,columns:integer;

begin

 readln(rows);

 readln(columns);

 for current_row := 1 to rows do begin

   writeln();

   for current_column := 1 to columns do begin

     read(a[current_row,current_column]);

     b[current_row,current_column] :=a [current_row,current_column] / 8;

   end;

 end;

 for current_row := 1 to rows do begin

   writeln();

   for current_column := 1 to columns do

     write(b[current_row,current_column]:4, ' ');

 end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано n-число дней с начала месяца. написать программу подсчета количества часов (has), минут(min) и секунд(sec) от начала месяца. входные данные n=5 выходные данные 120 7200 432000
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

slazurnaya
golovins3
club-pushkin
mishapavlov9
musaevartur
АнтонАртем
fruktovahere
arhangel1055
oldprince840
firsova5911
kettikis
nopel91668
diana8
tokarevmax
Ахмедшина Трубников1249