olgavlad199
?>

Написать программу-модель анализа датчика в помещении, которая выводит сообщение « ситуация», если температура в комнате превысила 60 град. с блок-схема

Информатика

Ответы

eshabunina
Программа на С:
int main(){
    float temp = receiveTemperature();
    if(temp > 60){
        printf("Пожароопасная ситуация");
    }
}
Блок-схема:
(начало)
    |
/temp/
     |
|temp = receiveTemperature()|
     |
<temp > 60>
     |        да
    +/"Пожароопасная ситуация"/--+
     | нет                                                             |
     +(конец)+
bagramyansvetlana
№ 1 Используя логические операции, запишите высказывания, которые являются истинными при выполнении следующих условий: 1) неверно, что 0 < X ≤ 3 и Y>5; 2) X является max(X,Y); 3) X не является min(X,Y); 4) Z является min(X,Y,Z). № 2 Используя логические операции, запишите высказывания, которые являются истинными при выполнении следующих условий: 1) Y не является max(X,Y,Z) и не является min(X,Y,Z); 2) X,Y,Z равны между собой; 3) каждое из чисел X,Y,Z положительно; 4) каждое из чисел X,Y,Z отрицательно.
len22
#include
необходим для подключения заголовочных файлов из стандартной библиотеки C/C++ (в этом случае название заголовочного файла указывается в угловых скобках, например, #include <cstdlib>) или заголовочных файлов сторонних библиотек (в этом случае название указывается в двойных кавычках, например, #include "sqlite3.h").

using namespace std
используется для выбора пространства имён std по-умолчанию. В библиотеках могут быть использованы различные пространства имён, ограничивающие область видимости функций, классов и глобальных переменных. В стандартной библиотеке используется пространство имён std, указывающее на то, что данная конструкция является частью стандартной библиотеки. Если не использовать никакое пространство имён, то даже при подключении заголовочного файла (например применив вызов #include <iostream>), мы не сможем явно использовать элементы этой библиотеки, которые объявлены в пространстве имён std. Т.е. вызов cout << "Привет, мир!" вызовет ошибку, что объект cout не найден. Это происходит потому, что данный объект имеет область видимости только внутри пространства имён std. Но мы можем его вызвать, явно указав, в каком пространстве имён следует искать данный объект. Для этого необходимо перед именем объекта указать имя пространства имён, в котором он находится. Пример:

#include <iostream>

int main()
{
     cout <<"Hello!"  // Ошибка - не указано пространство имён
     std::cout  <<"Hello!"  // Нет ошибки - вызов объекта из пространства имён std, указанного явным образом
}

как-то так...

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу-модель анализа датчика в помещении, которая выводит сообщение « ситуация», если температура в комнате превысила 60 град. с блок-схема
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ионов202
rimmatrotskaia303
Руслан Руденко1262
Vera_Shuklin
anovikovsr
zmlavra
Ямпольский
valueva260860
Aleksandrovich-Mayatskikh
zotovinbox468
mbykovskiy
delo1005
likakedo4ka439
Валиахметова
danya1509379