bezpalova2013
?>

C++ напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел. программа получает на входе целее числа, количество введённых чисел неизвестно, последовательность чисел заканчивается число 0 (0 - признак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введённые числа по модулю не превышают 30000. программа должна вывести одно число: разность максимального и минимального чисел.

Информатика

Ответы

ЛАРИСА Насоновская231
#include <iostream>
#include <vector>
using namespace std;
int main()
{
vector <int> v (1000);
int max = -30000;
int min = 30000;
for (int i = 0; i <1000; ++i) {
cin >> v[i];
if (v[i] == 0) break;
if (v[i] >= max) max = v[i];
if (v[i] <= min) min = v[i];
}
cout << max -min <<endl;
}
P7Y7V7

#include <stdlib.h>

#include <time.h>

#include <iostream>

using namespace std;

#define N 16

void main()

{

   int randomNumbers[N];

   srand(time(NULL));

   for (int i = 0;i < N; i++)

   {

       randomNumbers[i] = rand() % 40 - 20;

       cout << "randomNumber[" << i << "] = " << randomNumbers[i] << endl;

   }

   cout << endl;

   int counter = 0;

   for (int i = 0; i < N; i++)

   {

       if (randomNumbers[i] < 0)

       {

           counter++;

       }

   }

   cout << "counter = " << counter << endl;

}

bagramyansvetlana

1 - True/False

2 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания ложны.

3 - Конъюнкция

4 - X И Y И Z

5 - OR

6 - 1. Инверсия;

2. Конъюнкция;

3. Дизъюнкция;

4. Импликация;

5. Эквивалентность.

7 - логическая операция, которая преобразует исходное высказывание в новое, значение которого противоположно исходному.

8 - Импликация

9 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания истинны

10 -  Конъюнкция

11 - ?

12 - ?

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C++ напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел. программа получает на входе целее числа, количество введённых чисел неизвестно, последовательность чисел заканчивается число 0 (0 - признак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введённые числа по модулю не превышают 30000. программа должна вывести одно число: разность максимального и минимального чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Budanov317
Воронина
Sidunevgeniya
elenaowchinik4842
elenarumack
armsam76
Vrpeshka
dmitrievanata83538
egorsalnikov1997139
nkaminskaja
tarhan1221
kuharhuks
Fedorovich309
vasilevich-F
mkrtchyananaida6995