Вера1072
?>

Написать программу в паскале. даны два числа.меньшее из них замените полусуммой этих чисел, а большее - их произведением. составить блок-схему.

Информатика

Ответы

hrviko
Var a,b:integer;
begin 
writeln('a=');
readln(a);
writeln('b=');
readln(b);
if (a>b) then  begin 
b:=(a+b)/2;
a:=a*b;
 end
else 
begin 
a:=(a+b)/2;
b:=a*b;
end;
writeln('a=',a, ' b=', b);
readln;
end.
Abdullaev

№1 ответ: 133

№2 ответ: 40

№3 ответ: 60

№4 ответ: 1

№5 ответ: 6

Объяснение:

№1 Цикл "s:=s+12;" повторяется благодаря функции "for k:=1 to 11 do" и тем самым к переменной S мы 11 раз прибавляем 12. 1+11*12=133

№2 То же самое, но мы к переменной 5 раз (18-13) прибавляем 8. 8*5=40

№3 К переменной S сперва прибавляем переменную k 3 раза. Переменная k получает номер цикла, то есть в первый раз мы прибавляем 1, потом 2, потом уже 3. В конце программы просто умножаем на 10. S=(1+2+3)*10.

№4 Здесь для совершения цикла необходимо выполнить условие, а именно нужно, чтобы переменная i была больше 1, но из-за того что i у нас изначально равна 1, цикл "y := y + 1/i;  i := i - 1;" у нас не выполняется, а значит y=1

№5 В цикле repeat все действия выполняются сразу, но выход из цикла осуществится только при том условии, если i будет больше 5. К концу цикла у нас i будет равен 6, а значит цикл закончится и y будет равен 6 (y:=y+i).

iraira761

№1 ответ: 133

№2 ответ: 40

№3 ответ: 60

№4 ответ: 1

№5 ответ: 6

Объяснение:

№1 Цикл "s:=s+12;" повторяется благодаря функции "for k:=1 to 11 do" и тем самым к переменной S мы 11 раз прибавляем 12. 1+11*12=133

№2 То же самое, но мы к переменной 5 раз (18-13) прибавляем 8. 8*5=40

№3 К переменной S сперва прибавляем переменную k 3 раза. Переменная k получает номер цикла, то есть в первый раз мы прибавляем 1, потом 2, потом уже 3. В конце программы просто умножаем на 10. S=(1+2+3)*10.

№4 Здесь для совершения цикла необходимо выполнить условие, а именно нужно, чтобы переменная i была больше 1, но из-за того что i у нас изначально равна 1, цикл "y := y + 1/i;  i := i - 1;" у нас не выполняется, а значит y=1

№5 В цикле repeat все действия выполняются сразу, но выход из цикла осуществится только при том условии, если i будет больше 5. К концу цикла у нас i будет равен 6, а значит цикл закончится и y будет равен 6 (y:=y+i).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале. даны два числа.меньшее из них замените полусуммой этих чисел, а большее - их произведением. составить блок-схему.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

and-syr
ryadovboxing
proporcia46
konss2
horizma609
bolosolo77
Olgax732
vbnm100584
Zhilinoe134
inainainainaina0073
Эдуардович873
ksenyabobrovich7214
shneider1969
zhmulyov-denis8
shef3009
▲