betepah
?>

Написать программу с комментарием в с++ массив содержит четное количество элементов. напишите программу, которая сортируетпо возрастанию отдельно элементы первой и второй половин массива.каждый элемент должен остаться в своей половине. используйте алгоритм быстрой сортировки. пример массив: 53421632 после сортировки: 23456321.

Информатика

Ответы

cafemgimo

тут и обяснять особо нечего. сначала вычесляем сколько было "остальных" зрителей, потом общую сумму от продажи k1 человекам,  потом общую сумму от продажи k2(остальным) человекам, то и то складываем и присваиваем переменной sum.

program test; var k, k1, k2, c1, c2, sum: integer; begin    k: =894;     k1: =396;     c1: =150;     c2: =200;     k2: =k-k1;     sum: =k1*c1 + k2*c2;     writeln('sum = ', sum, ' rub'); end.

Aleksandrovich1415

- !

- !   вот вам меню.

- . я готова сделать заказ.

- да, .

- можно мне кусочек шоколадного торта и чашку зеленого чая?

- конечно. все будет готово через минуту.

- ! рада слышать это.

- вот ваш чай и ваш торт.

- !

- приятного
аппетита.

- !

(через пятнадцать минут) 

- извините, сколько мне платить?

- 190 рублей. 

- вот, . сдачи не надо.

- , приходите еще!

перевод:

- bună!

- bună! iată un meniu pentru dvs.

- mulțumesc. sunt gata să fac o
comandă.

- da, te rog.

"pot să am o felie de tort de ciocolată și o ceașcă de ceai verde? "

- bineînțeles. totul va fi gata într-un minut.

- mulțumesc! mă bucur să aud.

- iată ceaiul și prăjitura ta.

- mulțumesc!

- apetitul bun.

- mulțumesc!

(după cincisprezece minute)

- scuzați-mă, cât ar trebui să plătesc?

- 190 de ruble.

- aici ești. schimbarea nu este necesară.

- mulțumesc, vino din nou!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу с комментарием в с++ массив содержит четное количество элементов. напишите программу, которая сортируетпо возрастанию отдельно элементы первой и второй половин массива.каждый элемент должен остаться в своей половине. используйте алгоритм быстрой сортировки. пример массив: 53421632 после сортировки: 23456321.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

danceplusru
contact
Попова1271
demon8608
Shishkinaanasta1997
Михайлович1309
mado191065
Dr-motoshop
oyunabaduraeva
kon200182
aidapiltoyan43
snopovajulia
gdmaslo
Evagg3856
Aleksandrovich_Mitoyan1138
▲