shuramuji
?>

Написать программу для подсчета количества счастливых билетов выданных и оставшихся если ваш билет под № n

Информатика

Ответы

okunevo2010
function isLucky(a: integer): boolean;
var s: string;
begin  
    str(a, s);  
    while length(s) < 6 do s := '0' + s;  
    isLucky := ord(s[1]) + ord(s[2]) + ord(s[3]) = ord(s[4]) + ord(s[5]) + ord(s[6])
end;
var 
    sTicket: string;    
    iTicket, i, err, sum: longint;
begin  
    write('Введите Ваш номер билета: ');  
    read(sTicket);  
    val(sTicket, iTicket, err);  
    for i := 1 to iTicket do    
        if isLucky(i) then inc(sum);  
    writeln('Выдано ', sum, ' счастливых билетов');  
    writeln('Осталось выдать ', 55251 - sum, ' счастливых билетов')
end.
Panei

ответ:

объяснение:

    используем формулу нахождения объема:

    i = m x n * i

    подсчитаем каждый сомножитель в формуле, стараясь числа к степеням двойки:

    m x n:

    160 * 160 = 20 * 2³ *   20 * 2³ = 400 * 26 =

    = 25 * 24 * 26

    нахождение глубины кодирования i:

    256 = 28

    т.е. 8 бит на пиксель   (из формулы кол-во цветов = 2i)

    находим объем:

    i = 25 * 24 * 26 * 23 = 25 * 213 - всего бит на всё изображение

    переводим в кбайты:

    (25 * 213) / 213 = 25 кбайт

Doronin755

видеока́рта (также видеоада́птер, графический ада́птер, графи́ческая пла́та, графи́ческая ка́рта, графи́ческий ускори́тель) — устройство, преобразующее графический образ, хранящийся как содержимое памяти компьютера (или самого адаптера), в форму, пригодную для дальнейшего вывода на экран монитора. первые мониторы, построенные на электронно-лучевых трубках, работали по телевизионному принципу сканирования экрана электронным лучом, и для отображения требовался видеосигнал, генерируемый видеокартой.

однако эта базовая функция, оставаясь нужной и востребованной, ушла в тень, перестав определять уровень возможностей формирования изображения — качество видеосигнала (чёткость изображения) мало связано с ценой и техническим уровнем современной видеокарты. в первую очередь, сейчас под графическим адаптером понимают устройство с графическим процессором — графический ускоритель, который и занимается формированием самого графического образа. современные видеокарты не ограничиваются простым выводом изображения, они имеют встроенный графический процессор, который может производить дополнительную обработку, снимая эту с центрального процессора компьютера. например, все современные видеокарты nvidia и amd (ati) осуществляют рендеринг графического конвейера opengl и directx и vulcan на аппаратном уровне. в последнее время также имеет место тенденция использовать вычислительные возможности графического процессора для решения неграфических .

обычно видеокарта выполнена в виде печатной платы (плата расширения) и вставляется в разъём расширения, универсальный либо специализированный (agp, pci express). также широко распространены и встроенные (интегрированные) в системную плату видеокарты — как в виде отдельного чипа, так и в качестве составляющей части северного моста чипсета или цпу; в этом случае устройство, строго говоря, не может быть названо видеокартой.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для подсчета количества счастливых билетов выданных и оставшихся если ваш билет под № n
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Adno1578
kostavaani
terehin863
vikapar2646
ruslanriad10
Семеновна-Павел
mileva84
natura-domA90
Rustamov741
yna21289
uksusoval617
Tatyanaaarzieva72
antilopa001
ooo-krasa
rsksnb