Как зрим из вышеизложенного, описание цвета имеет возможность опираться на формирование всякого цвета на базе ведущих цветов или же на эти мнения, как светлота, насыщенность, цветовой тон. Применительно к компьютерной графике описание цвета еще надлежит принимать во внимание специфику аппаратуры для ввода/вывода изображений. В связи с потребностью описания всевозможных телесных процессов проигрывания цвета были разработаны всевозможные цветовые модели. Цветовые модели дают возможность с поддержкой математического аппарата обрисовать конкретные цветовые области диапазона. Цветовые модели обрисовывают цветовые оттенки с поддержкой смешивания нескольких ведущих цветов.
Поделитесь своими знаниями, ответьте на вопрос:
100 . напишите программу, которая содержит тест (pascal) не забудьте сделать заставку. тест "приятно ли с вами общаться? " если человек общителен, то это еще не значит, что с ним приятно разговаривать. есть люди, которые своей общительностью каждому буквально с первых минут разговора. посмотрите внимательно, разве мало вокруг таких людей? а вы приятный собеседник? 1) вы любите больше слушать, чем говорить? 2) вы всегда можете найти тему для разговора, даже с незнакомым человеком? 3) вы всегда внимательно слушаете собеседника? 4) любите ли вы давать советы? 5) если тема разговора вам не интересна, станете ли показывать это собеседнику? 6) раздражаетесь, когда вас не слушают? 7) у вас есть собственное мнение по любому вопросу? 8) если тема разговора вам не знакома, станете ли вы ее развивать? 9) вы любите быть центром внимания? 10) есть ли хотя бы три предмета, по которым вы обладаете достаточно прочными знаниями? 11) вы хороший оратор? если вы положительно ответили на вопросы 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, то можете засчитывать себе по одному за каждый из них. а теперь посчитаем: 1-3 : трудно сказать, то ли вы молчун, из которого не вытянешь ни слова, то ли настолько общительны, что вас стараются избегать, но факт остается фактом: общаться с вами далеко не всегда приятно, а порой даже тяжело. вам бы следовало над этим задуматься. 4-9 : вы, может быть, и не слишком общительный человек, но почти всегда внимательный и приятный собеседник. вы можете быть и весьма рассеянным, когда не в духе, но не требуете от окружающих в такие минуты особого внимания к вашей персоне. 10--11 : вы, наверное, один из самых приятных собеседников, друзья не могут без вас обойтись
var a,b,c,d,e,f,g,h,j,k,l,s: integer;
begin
s:=0;
writeln ('Тест "Приятно ли с вами общаться?" Если человек общителен, то это еще не значит, что с ним приятно разговаривать. Есть люди, которые своей общительностью надоедают каждому буквально с первых минут разговора. Посмотрите внимательно, разве мало вокруг таких людей? А вы приятный собеседник?');
writeln ('1) Вы любите больше слушать, чем говорить?');
writeln ('1 да, 2 нет');
readln (a);
if a=1 then s:=s+1 else s:=s+0;
writeln ('2) Вы всегда можете найти тему для разговора, даже с незнакомым человеком?');
writeln ('1 да, 2 нет');
readln (b);
if b=1 then s:=s+1 else s:=s+0;
writeln ('3) Вы всегда внимательно слушаете собеседника? ');
writeln ('1 да, 2 нет');
readln (c);
if c=1 then s:=s+1 then s:=s+0;
writeln ('4) Любите ли вы давать советы?');
writeln ('1 да, 2 нет');
readln (d);
if d=1 then s:=s+1 else s:=s+0;
writeln ('5) Если тема разговора вам не интересна, станете ли показывать это собеседнику?');
writeln ('1 да, 2 нет');
readln (e);
if e=1 then s:=s+1 else s:=s+0;
writeln ('6) Раздражаетесь, когда вас не слушают?');
writeln ('1 да, 2 нет');
readln (f);
if f=1 then s:=s+1 else s:=s+0;
writeln ('7) У вас есть собственное мнение по любому вопросу?');
writeln ('1 да, 2 нет');
readln (g);
if g=1 then s:=s+1 else s:=s+0;
writeln ('8) Если тема разговора вам не знакома, станете ли вы ее развивать?');
writeln ('1 да, 2 нет');
readln (h);
if g=h then s:=s+1 else s:=s+0;
writeln ('9) Вы любите быть центром внимания?');
writeln ('1 да, 2 нет');
readln (j);
if j=1 then s:=s+1 else s:=s+0;
writeln ('10) Есть ли хотя бы три предмета, по которым вы обладаете достаточно прочными знаниями?');
writeln ('1 да, 2 нет');
readln (k);
if k=1 then s:=s+1 else s:=s+0;
writeln ('11) Вы хороший оратор?');
writeln ('1 да, 2 нет');
readln (l);
if l=1 then s:=s+1 else s:=s+0;
writeln ('Ваши - ', s);
writeln ('1- : Трудно сказать, то ли вы молчун, из которого не вытянешь ни слова, то ли настолько общительны, что вас стараются избегать, но факт остается фактом: общаться с вами далеко не всегда приятно, а порой даже тяжело. Вам бы следовало над этим задуматься. 4- : Вы, может быть, и не слишком общительный человек, но почти всегда внимательный и приятный собеседник. Вы можете быть и весьма рассеянным, когда не в духе, но не требуете от окружающих в такие минуты особого внимания к вашей персоне.10- : Вы, наверное, один из самых приятных собеседников, друзья не могут без вас обойтись');
end.