thebest59
?>

На вход программы подается n чисел, при том известно, что хотя бы одно из них окажется чётным. определите наибольшее четное число. -в первой строке вводится натуральное число n, (1≤n≤1000) — количество элементов последовательности. в следующей строке через пробел вводятся n целых чисел, каждое из которых по модулю не превосходит 1000. -требуется вывести единстенное число — искомый четный максимум. например 3 2 8 4 8

Информатика

Ответы

ilez03857
#include< iostream> #include< windows.h> #include< locale> int main() {     setlocale(lc_all, "russian");     int a, b;     int   n;     std: : cout < < "введите числитель: ";     std: : cin > > a;     std: : cout < < "введите знаменатель: ";     std: : cin > > b;     n = a < b ? a: b;     for(int i=1; i< =n; i++)       %i) & & ! (b%i))        {          a/=i;           b/=i;         }     std: : cout < < " " < < a < < " \n" < < "";     if(b == 1)  std: : cout < < " = " < < a;     std: : cout < < "\n " < < b < < " \n";       system("pause");     return 0; }
Новиков1139
1var x,y: integer; begin   writeln('введите х');   readln(x);   writeln('введите y');   readln(y);   if x< y then writeln('меньшее: ',x) else   if x> y then writeln('меньшее: ',y) else   if x=y then writeln('числа равны') end. 2 var x,y: integer; begin   writeln('введите первое число');   readln(x);   writeln('введите второе число');   readln(y);   if y=0 then writeln('второе число равно 0. деление невозможно! ') else   writeln(x,'/',y,'=',x/y); end. 3 var s,name: string; begin   writeln('введите ваше имя');   readln(name);   writeln('введите строку');   readln(s);   if s=name then writeln('! ') else   writeln('! '); end. 4 var x: integer; begin   writeln('введите число');   readln(x);   if (x mod 2)=0 then writeln('четное') else writeln('нечетное') end. 5 var x: string; i: integer; begin   writeln('введите строку');   readln(x);   writeln('введите номер символа');   readln(i);   if i > length(x) then writeln('нет символа! ') else writeln(x[i]) end. 6 var x,y: integer; begin   writeln('количество яблок: ');   readln(x);   writeln('количество апельсинов: ');   readln(y);   if (x*100)> (y*150) then writeln('берите яблоки')   else   if (x*100)< (y*150) then writeln('берите апельсины')   else   if (x*100)=(y*150) then writeln('вес яблок и апельсинов одинаковый') end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На вход программы подается n чисел, при том известно, что хотя бы одно из них окажется чётным. определите наибольшее четное число. -в первой строке вводится натуральное число n, (1≤n≤1000) — количество элементов последовательности. в следующей строке через пробел вводятся n целых чисел, каждое из которых по модулю не превосходит 1000. -требуется вывести единстенное число — искомый четный максимум. например 3 2 8 4 8
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Plamia7917
dream2366
fox-cab3444
Norov
Minchenkova
Playintim405374
fedorenkoroman
Aleksandrovich1075
ЕленаГерасимова
kolefe22171
Ivanovna
Viktoromto
shugayzhanna6
rstas
germanleon
▲