marvindkc
?>

Составить программы для решения на языке паскаль abc: 1)определить, является ли целое число n кратным числу 5. 2)определить, является ли число c средним арифметическим чисел a и b (a, b, c - вводятся с клавиатуры 3)компьютер спрашивает: "сколько вам лет? ". если ответ меньше 14, то отвечает "вам еще рано получать паспорт". если ответ больше или равен 14 отвечает "поздравляю! вы гражданин россии! ". 4)составить программу, которая запрашивает ввод температуры тела человека и определяет, здоров он или болен (здоров при 36 < t < 37)

Информатика

Ответы

elaginaelena70
1)var
n:longint;
begin
readln(n);
if n mod 5=0 then writeln('Число N является кратным чилслу 5')else
writeln('Чило N не является кратным числу 5' );
end.
2)
var
a,b,c:longint:
begin
readln(a,b,c);
if (a+b)div 2=c then writeln('Число C является средним арефметическим чисел A и B') else writeln(' Число C является средним арефметическим чисел A и B') else writeln('Число C не является средним арефметическим чисел A и B ');
end.
3)
var
a:longint;
begin
write('Сколько вам лет?');
readln(a);
if a<14 then write('Вам еще рано получать паспорт?') else write('Поздравляю! Вы гражданин России!');
end.
4)
var
a:extended;
begin
readln(a);
if (a>36)and(a<37) then writeln('Вы здоровы') else writeln('Вы больны');
end.
donertime8
Год создания первого компьютера - 1938 год, машина Z1, инженер Конрад Цузе. Первым функционирующим программируемым компьютером принято считать Z3(1941 год) этого же инженера.

Год создания первого отечественного компьютера- 1951 год, МЭСМ, разработана группой Лебедева в Киеве.

Год открытия радиосвязи- 1995 год, изобретатель А. С. Попов

Год первого полета человека в космос- 1961 год, Ю. Гагарин

Год принятия христианства на Руси- 988 год.

Год первого упоминания в летописи о Москве- 1147 год, летопись "Москва"

Год начала великой отечественной войны- 1941 год, 

Год запуска первого искусственного спутника земли- 1957 год,  «Спутник-1», СССР

Год открытия Колумбом Америки- 1492 год.
gullieta

const

   handsfree = false;

   nmax = 10;

   random_min = -50;

   random_max = 50;

var

   a: array[0..nmax] of real;

   i, n: integer;

   sum, x: real;

begin

   {ввод массива}

   n := nmax;

   if handsfree then begin

       for i := 0 to n do

       begin

           a[i] := random(random_max - random_min) + random_min;

           write(a[i], ' ');

       end

   end

   else begin

       for i := 0 to n do

           readln(a[i]);

   end;

   writeln();

   

   {подсчет суммы}

   write('x = ');

   readln(x);

   

   sum := a[n];

   for i := n - 1 downto 0 do

       sum := sum * x + a[i];

   writeln('S = ', sqrt(sum));

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программы для решения на языке паскаль abc: 1)определить, является ли целое число n кратным числу 5. 2)определить, является ли число c средним арифметическим чисел a и b (a, b, c - вводятся с клавиатуры 3)компьютер спрашивает: "сколько вам лет? ". если ответ меньше 14, то отвечает "вам еще рано получать паспорт". если ответ больше или равен 14 отвечает "поздравляю! вы гражданин россии! ". 4)составить программу, которая запрашивает ввод температуры тела человека и определяет, здоров он или болен (здоров при 36 < t < 37)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Shumnova42
YekaterinaAbinskov
anchutk3016
msk27
gk230650
elenakarpova709
samogon-mozhaisk
Olia72
tatianaesipenko
mskatrinmadness
seleznev1980
ERodina1
beaevgen711
Romanovna-yana
Владислав-Александр32