laktionova-natal
?>

Составьте программу по которой компьютер десять раз запросит ввод целых и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных. паскаль, соответственно.

Информатика

Ответы

igorshevkun
Var a,b,c,d:integer;
begin
for a:=1 to 10 do begin
  write('введите число=> ');
  readln(d);
  if (d mod 2=0) then c:=c+1 else d:=d+1;
  end;
writeln('чётных=> ',c,' нечётных=> ',d);
end.
amayonova
Program znanija;
var s,nc,c,i:integer;
begin

for i:=1 to 10 do 
begin   
read(s);   
if odd(s) then inc(nc);   
if not odd(s) then inc(c); 
end;  

writeln('Чётных: ',c,' Не чётных: ', nc);

end.
dionissia2

1)    15 Кбайт

2)   7 или 6 (см. объяснения)

Объяснение:

1)

V = K * i, где

V - это информационный объём текстового сообщения (размер файла, содержащего сообщение)

K - количество символов в сообщении

i - информационный вес одного символа (число бит, используемых для записи одного символа)

Дано:

К = 16 страниц x 30 строк x 32 символа = 15 360 символов

i = 8 бит

Найти:

V

V = K * i = 15 360 * 8 = 122 880 бит

V = 122 880 бит = 122 880 / 8 = 15 360 байт = 15 360 / 1024 = 15 Кбайт

2)

Очень странная таблица (смотри картинку). Не совпадают цифры в расстояниях между CD-DC и CF-FC.

Построим граф по данным таблицы (смотри картинку).

Если мы возьмём значения CD-DC = 2 и CF-FC = 4 (чёрные цифры на картинке), то самым коротким путём будет ACEF = 4 + 2 + 1 = 7

Если мы возьмём значения CD-DC = 4 и CF-FC = 2 (красные цифры на картинке), то самым коротким путём будет ACF = 4 + 2 = 6


Статья, набранная на компьютере, содержит 16 страниц, на каждой странице 30 строк, в каждой строке 3
Статья, набранная на компьютере, содержит 16 страниц, на каждой странице 30 строк, в каждой строке 3
museumuzl

1)    15 Кбайт

2)   7 или 6 (см. объяснения)

Объяснение:

1)

V = K * i, где

V - это информационный объём текстового сообщения (размер файла, содержащего сообщение)

K - количество символов в сообщении

i - информационный вес одного символа (число бит, используемых для записи одного символа)

Дано:

К = 16 страниц x 30 строк x 32 символа = 15 360 символов

i = 8 бит

Найти:

V

V = K * i = 15 360 * 8 = 122 880 бит

V = 122 880 бит = 122 880 / 8 = 15 360 байт = 15 360 / 1024 = 15 Кбайт

2)

Очень странная таблица (смотри картинку). Не совпадают цифры в расстояниях между CD-DC и CF-FC.

Построим граф по данным таблицы (смотри картинку).

Если мы возьмём значения CD-DC = 2 и CF-FC = 4 (чёрные цифры на картинке), то самым коротким путём будет ACEF = 4 + 2 + 1 = 7

Если мы возьмём значения CD-DC = 4 и CF-FC = 2 (красные цифры на картинке), то самым коротким путём будет ACF = 4 + 2 = 6


Статья, набранная на компьютере, содержит 16 страниц, на каждой странице 30 строк, в каждой строке 3
Статья, набранная на компьютере, содержит 16 страниц, на каждой странице 30 строк, в каждой строке 3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу по которой компьютер десять раз запросит ввод целых и в результате сообщит сколько среди введённых чисел чётных и сколько нечётных. паскаль, соответственно.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

barnkim
maximpr6
sky-elena712558
modellisimo-a
gbelihina
marat7
Иванович621
Кирилл-Анна1023
Dubovitskayae
zoyalexa495
stasyan
sdvigov
ekaizer
irschacha
viz-art-pnz1664