спец387
?>

Написать программу на языке паскаль. дано число n. в интервале от 1 до n сложить все числа, которые делятся на 3, и перемножить все, делящиеся на 2.

Информатика

Ответы

Sergei
Var n,a,b,c:integer;
begin
write('введите длину интервала: ');
readln(n);
a:=0;
c:=1;
for b:=1 to n do begin
if (b mod 3 =0) then a:=a+b;
if (b mod 2=0) then c:=c*b;
end;
writeln('сумма делящихся на 3=> ',a);
writeln('произведение делящихся на 2=> ',c);
end.
brakebox
В общем случае, трассировка - один из отладки программ врукопашную: состояние программы контролируется на определённом отрезке времени её выполнения путём анализа значений переменных. трассировка в том или ином виде при отладке программ сложнее школьного дз практически неизбежна.
в простейшем случае, трассировка - вывод значений переменных на экран (например, в окно консоли) , либо расчёт их на бумажке для каждого шага.
в более продвинутом варианте используются точки останова, окно наблюдения, выполнение по шагам и, если есть, контекстный интерпретатор выражений.
есть также специальная "трассирующая консоль" - интерфейс вывода информации из программы в отладчик, если таковой присутствует.
почти любой современный отладчик показывает состояние програмm при её останове, что делает трассировку процессом легко доступным
elenaneretina
Алгоритм
1) a x a = a² ⇒ b;    b x a = a³ ⇒ результат
2) a x a = a² ⇒ b;    b x b = a⁴ ⇒ c;   c x c = a⁸ ⇒ c;   c x b = a¹⁰ ⇒ результат

Программа на языке PascalABC.Net
var
  a,b,c,y:real;
begin
  Write('Введите число: '); Read(a);
  b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
  c:=b*b; c:=c*c; y:=b*c;
  Writeln('Десятая степень числа равна ',y)
end.

Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024

Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке паскаль. дано число n. в интервале от 1 до n сложить все числа, которые делятся на 3, и перемножить все, делящиеся на 2.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

СмыковаДарья1969
Lugovoi
sryzhova6392
Lapushkina
Ushakova Sakhno
seleznev1980
omigunova39
Смирнов-Оськина
ЮлияДаниил520
Дмитрий_Владимирович1162
Микроволновые системы что это​
mariashapar
Rafigovich1267
Mexx9050
bulenbeiser
ИП-Сысоев1628