derkachn6429
?>

Написать программу на языке c++. дано четырёхзначное число. поменять в нем число дестков и число тысяч. найти наибольшую и наименьшую цифру. определить - делится ли это число на 2? на 7? на 123? подсчитать число четных цифр.

Информатика

Ответы

balabina-Olesya

#include

using namespace std;

int main() {

setlocale(lc_all, "russian");

    int n, a, b, c, d, e, f, k=0;

    cin > > n;

    a=n%10;

    b=n%100/10;

    c=n%1000/100;

    d=n/1000;

    e=n-c*100-b*10+c*10+b*100;

    cout<

    if (a%2==0)++k; if (b%2==0)++k; if (c%2==0)++k; if (d%2==0)++k;

    f=a; if (b

    if (b> a) a=b; if (c> a) a=c; if (d> a) a=d;

    cout< < "наименьшая цифра числа "<

    if (n%2==0)cout< < "число делится на 2"<

    else cout< < "число не делится на 2"<

    if (n%7==0)cout< < "число делится на 7"<

    else cout< < "число не делится на 7"<

    if (n%123==0)cout< < "число делится на 123"<

    else cout< < "число не делится на 123"<

    cout< < "число четных цифр в числе равно "<

    return 0;

}

saltikovaK.S.1482
Using  system; using  system.io; using  system.linq; namespace  fileapp {         class  mainclass         {                            private  static  int  multicast(char  first,char  second,  int  system)                 {                         return  convert.toint32(first.  system)  *  convert.toint32(second.  system);                 }                 private  static  void  method(string  numberstring,int  system)                 {                         int  firstandsecond  =  multicast(numberstring[0],  numberstring[1],  system);   //  первые  два                         int  lastandprevious  =  multicast(numberstring.  numberstring[numberstring.length  -  2],  system);   //последний  и  предпоследний                         int  firstandlast  =  multicast(numberstring.  numberstring.  system);   //  первый  и  последний                                                 console.writeline($"произведение  первых  двух  цифр:   {firstandsecond}");                         console.writeline($"произведение  последних  двух  цифр:   {lastandprevious}");                         console.writeline($"произведение  первой  и  последней  цифры:   {firstandlast}");                 }                 public  static  void  main(string[]  args)                 {                         console.write("введите  число:   ");                         string  numberstring  =  console.readline();   //число  в  виде  строки                         console.write("выберите  систему  счисления:   ");                         int  system  =  convert.toint32(console.; //система  счисления                         method(numberstring,  system);                         console.readline(); //задержка                 }         } }
ivanovanata36937365
Program znanija; var       a, res: array of integer;       x, n, i, k: integer; begin       readln(n);       setlength(a,n);       setlength(res,n);             for i : = 0 to n - 1 do               readln(a[i]);                     k : = 0;       for i : = 0 to n - 1 do                     if a[i] mod 3 = 0 then                     begin                             res[k] : = a[i];                             k : = k + 1;                     end;       for i : = 0 to k - 1 do               writeln(res[i]);         end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке c++. дано четырёхзначное число. поменять в нем число дестков и число тысяч. найти наибольшую и наименьшую цифру. определить - делится ли это число на 2? на 7? на 123? подсчитать число четных цифр.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Kulikovvl9
inaine73
shilinmikhaillg
nastya3213868
Александрович_Викторовна
reznikvi
galiyamart6671
asl09777
andreanikin
galtig83
evgeniishulov4696
Olia72
Svatela37
mariia39
dilbaryan76