galkavik
?>

Составить программу которая в зависимости от введенного значения температуры воздуха (от -50 до 50 градусов) выводит на экран сообщения типа: -50 - холодно, 50 жакро и т.д. на языке basic

Информатика

Ответы

OlgaVasilevna
QBasic

INPUT "Введите температуру: ", t
SELECT CASE t
CASE IS < -50
   PRINT "Крайне холодно"
CASE IS <= -30
   PRINT "очень холодно!"
CASE IS <= -10
   PRINT "холодно"
CASE IS <= 10
   PRINT "Прохладно"
CASE IS <= 25
   PRINT "Тепло"
CASE IS <= 30
   PRINT "жарко"
CASE IS <= 40
   PRINT "очень жарко!"
CASE ELSE
   PRINT "крайне жарко!"
END SELECT
akbmaslafarkop3175
INPUT t
IF t<=-10 THEN PRINT "ОЧЕНЬ ХОЛОДНО!"
IF t>-10 AND t<=5 THEN PRINT "ХОЛОДНО!"
IF t>5 AND t<=15 THEN PRINT "ПРОХЛАДНО"
IF t>15 AND t<=23 THEN PRINT "ТЕПЛО"
IF t>23 AND t<=30 THEN PRINT "ЖАРКО"
IF t>30 AND t<=40 THEN PRINT "ОЧЕНЬ ЖАРКО!"
IF t>40 AND t<=50 THEN PRINT "ПУСТЫНЯ!"
household193
1. "Школьное" решение

// PascalABC.NET 3.0, сборка 1073
const
  sb='bcdfgjklmnpqrstvwxz';
  s='Computer programming is a process of computer programs creation';
var
  i,n:integer;
  s1,sn,t:string;
begin
  i:=1;
  while s[i]<>' ' do Inc(i);
  s1:=Copy(s,1,i-1);
  n:=Length(s); i:=n;
  while s[i]<>' ' do Dec(i);
  sn:=Copy(s,i+1,n-i);
  t:='';
  for i:=1 to Length(s1) do
    if Pos(s1[i],sb)>0 then t:=t+s1[i];
  s1:=t;
  t:='';
  for i:=1 to Length(sn) do
    if Pos(sn[i],sb)>0 then t:=t+sn[i];
  sn:=t;
  t:='';
  for i:=1 to Length(s1) do
    if Pos(s1[i],sn)>0 then
      if Pos(s1[i],t)=0 then t:=t+s1[i];
  for i:=1 to Length(t) do Write(t[i],' ');
  Writeln
end.
 
Тестовый прогон:
t r

2. "Нормальное" решение

// PascalABC.NET 3.0, сборка 1073
const
  sb='bcdfgjklmnpqrstvwxz';
  s='Computer programming is a process of computer programs creation';
begin
  var a:=s.ToWords(' ');
  a[0].Intersect(a[a.Length-1]).Where(x->Pos(x,sb)>0).Println(',')
end.

Тестовый прогон:
t,r
Svetlana395
Var a:array of array of integer;
c:array of array of integer;
ma:array of array of integer;
i,j,n:integer;
begin;
randomize;
readln(n);
setlength(a,n+1); //задаём размерность динамических массивов
setlength(c,n+1);
setlength(ma,n+1);
for i:=1 to n do
begin;
setlength(a[i],n+1);
setlength(c[i],n+1);
setlength(ma[i],n+1);
end;

writeln('Matrix A:');   //генерируем массив псеводслучайных чисел
for i:=1 to n do begin;
 writeln;
  for j:=1 to n do
   begin;
    a[i,j]:=random(10);
    write(a[i,j]:4);
   end;
 end;
writeln;

writeln('Matrix C:'); //аналогично
for i:=1 to n do
 begin;
 writeln;
  for j:=1 to n do
   begin;
    c[i,j]:=random(10);
    write(c[i,j]:4);
   end;
 end;

for i:=1 to n do     //сохраняем матрицу C для транспонации
  for j:=1 to n do
    ma[i,j]:=c[i,j];
    writeln;

writeln('Transpose matrix C:'); //транспонируем C
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     c[i,j]:=ma[j,i];
     write(c[i,j]:4);
    end;
 end;

writeln;
writeln('Final matrix:'); // получаем финальную матрицу
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     ma[i,j]:=2*c[i,j]*a[i,j];
{по свойству дистрибутивности матриц С(A+A)=C*A+C*A=2*C*A}
     write(ma[i,j]:4);
    end;
 end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая в зависимости от введенного значения температуры воздуха (от -50 до 50 градусов) выводит на экран сообщения типа: -50 - холодно, 50 жакро и т.д. на языке basic
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sahar81305
PopovViktorovna
mgrunova3966
сергей1246
shpakohat
mototeh69
Евгеньевна_Хусинов
Janaz842060
Radikovnanikolaeva
alekseymedvedev1981
restkof
fafina12586
iraimironova
platonm777639
X2755070
▲